Ask Your Question
0

devstack installation failure: Discovering versions from the identity service

asked 2016-03-24 13:52:33 -0500

KP gravatar image

updated 2016-03-24 14:44:23 -0500

dbaxps gravatar image

Hello, My latest openstack installation using devstack from master branch fails with the following error:

2016-03-24 18:12:08.515 | 2016-03-24 11:12:08.514 3355 INFO keystone.cmd.cli [req-ec2ff80e-427a-4cb3-ac92-201b619054b6 - - - - -] Created public endpoint http://172.28.12.92:5000/v2.0
2016-03-24 18:12:10.514 | Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
2016-03-24 18:12:10.514 | Could not determine a suitable URL for the plugin
2016-03-24 18:12:10.558 | Error on exit
2016-03-24 18:12:10.902 | df: '/run/user/114/gvfs': Permission denied

This seems similar to:
ttps://bugs.launchpad.net/openstack-manuals/+bug/1454049
https://ask.openstack.org/en/question...

But, i don't see the solution there. This setup was earlier running the juno release which i unstacked and also ran ./clean.sh. Server was rebooted as well.

My local.conf is as follows:

HOST_IP=172.28.12.92
RABBIT_PASSWORD=guest
RABBIT_USERID=guest
SERVICE_TOKEN=abc123
SERVICE_PASSWORD=abc123
ADMIN_PASSWORD=abc123
MYSQL_PASSWORD=abc123
DATABASE_TYPE=mysql
SERVICE_HOST=$HOST_IP
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

# Enable/Disable services
enable_service n-sch
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service neutron
enable_service q-dhcp
enable_service q-l3
disable_service tempest

[keystone_authtoken]
auth_host=$SERVICE_HOST
admin_tenant_name=service
admin_user=neutron
admin_password=$ADMIN_PASSWORD

Any help on this would be great.

Thanks, KP

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-19 03:32:00 -0500

aamir gravatar image

I had the same problem. In my case I am installing devstack on ubuntu running inside a virtual machine and problem was HOST_IP that I set in local.conf file which is used by the installation script.

HOST_IP should be same as one of IP interface addr configured on the host machine. So for me it worked when I set HOST_IP to 192.168.122.1 as my IP config on VM looked like

aamir@OpenStackDesk:~/openstack/devstack$ ip ad sh
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:cf:dc:24 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fecf:dc24/64 scope link 
       valid_lft forever preferred_lft forever
3: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 8a:78:81:a7:6c:b4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-03-24 13:52:33 -0500

Seen: 5,450 times

Last updated: Apr 19 '16