No linux bridge agent in neutron agent-list

asked 2016-03-23 14:19:41 -0600

Nogginboink gravatar image

Following the installation guide for Liberty on Ubuntu Server 14.04LTS, when I run neutron agent-list on the controller, I see the DHCP agent, the L3 agent, and the metadata agent, but the linuxbridge agent doesn't show up on either the controller node nor on the compute node:

admin@<CONTROLLER>:~$ neutron agent-list
+--------------------------------------+----------------+--------+-------+----------------+------------------------+
| id                                   | agent_type     | host   | alive | admin_state_up | binary                 |
+--------------------------------------+----------------+--------+-------+----------------+------------------------+
| 3abca8d4-c2f8-4347-9d6c-7390d8542223 | DHCP agent     | <CONTROLLER>| :-)   | True           | neutron-dhcp-agent     |
| 6b0937a2-2a94-4101-9479-b677698a2dd5 | L3 agent       | <CONTROLLER>| :-)   | True           | neutron-l3-agent       |
| 7dbc3875-afa6-46ba-879e-5cf4740d96b8 | Metadata agent | <CONTROLLER>| :-)   | True           | neutron-metadata-agent |
+--------------------------------------+----------------+--------+-------+----------------+------------------------+

The linux bridge service is running on the controller node:

admin@<CONTROLLER>:~$ sudo service neutron-plugin-linuxbridge-agent status
neutron-plugin-linuxbridge-agent start/running, process 3929

/etc/neutron-plugin-linuxbridge-agent.log shows:

2016-03-23 14:07:32.246 4267 INFO neutron.common.config [-] Logging enabled!
2016-03-23 14:07:32.246 4267 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 7.0.3
2016-03-23 14:07:32.246 4267 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {'public': 'em1'}
2016-03-23 14:07:32.246 4267 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2016-03-23 14:07:32.247 4267 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Agent initialized successfully, now running...
2016-03-23 14:07:32.313 4267 ERROR neutron.agent.linux.utils [-]
Command: ['sudo', 'ip', 'link', 'add', 'vxlan-1', 'type', 'vxlan', 'id', '1', 'dev', 'em1', 'proxy']
Exit code: 1
Stdin:
Stdout:
Stderr: sudo: no tty present and no askpass program specified

I'm afraid that doesn't give this newbie much to go on. My /etc/neutron/plugins/ml2/linuxbridge_agent.ini file looks like:

[linux_bridge]
physical_interface_mappings = public:em1

[vxlan]
enable_vxlan = True
local_ip = 10.x.y.z
l2_population = True

[agent]
prevent_arp_spoofing = True

[securitygroup]
enable_security_group = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

neutron.conf looks like:

[DEFAULT]
core_plugin = ml2
service_plugins = router
allow_overlapping_ips = True
rpc_backend = rabbit
auth_strategy = keystone
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://<CONTROLLER>:8774/v2
verbose = True

[nova]
auth_url = http://<CONTROLLER>:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
region_name = RegionOne
project_name = service
username = nova
password = <NOVAPASS>



[keystone_authtoken]
auth_uri = http://<CONTROLLER>:5000
auth_url = http://<CONTROLLER>:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = neutron
password = <NEUTRONPASS>

[oslo_messaging_rabbit]
rabbit_host = <CONTROLLER>
rabbit_userid = openstack
rabbit_password = <RABBITPASS>

[database]
connection = mysql+pymysql://neutron:<NEUTRONPASS>@<CONTROLLER>/neutron

Any help would be appreciated!

edit retag flag offensive close merge delete

Comments

These need to be real addresses, either looked up via dns/hosts...

auth_uri = http://<CONTROLLER>:5000
auth_url = http://<CONTROLLER>:35357

Similarly here and all the other places that are in <>

connection = mysql+pymysql://neutron:<NEUTRONPASS>@<CONTROLLER>/neutron
BobH gravatar imageBobH ( 2016-03-27 10:16:06 -0600 )edit

Bob, they are real addresses in my real file. I just 'sanitized' the files for public posting.

Nogginboink gravatar imageNogginboink ( 2016-03-28 11:31:28 -0600 )edit

Figured... The only other thing I noticed is the physical:em1. em1 is not a typical interface name, but I bet that's on purpose as well. I guess another shot in the dark, Is the linux bridge running on the comopute node? See the process running?

BobH gravatar imageBobH ( 2016-03-28 21:07:48 -0600 )edit

Can you share the ml2_conf.ini contents as well? I have been using this combination without a problem.

SriramS gravatar imageSriramS ( 2016-04-04 12:48:27 -0600 )edit

I guess you found the problem? For me looks like that sudo requires a tty:

Stderr: sudo: no tty present and no askpass program specified

check your /etc/sudoers if you have something like requiretty. Remove it.

bertly gravatar imagebertly ( 2016-06-02 03:28:56 -0600 )edit