Ask Your Question
1

How to properly configure veta nova-client?

asked 2013-12-18 00:49:10 -0500

updated 2013-12-20 16:31:58 -0500

smaffulli gravatar image

i have configured veta nova-client, whenever i click on the veta menu in horizan dashboard i kicked out of the session

Also i am trying to check veta-client by CLI and getting below error

 **nova backup-schedule-add 1c62b8b4-8f82-404a-8e1f-4a2a229c89ff 1h 1d**
ERROR: There is no such action: backup_schedule_add (HTTP 400) (Request-ID: req-9b775675-3f40-425d-881e-c9665eb272b7)
edit retag flag offensive close delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-22 16:25:49 -0500

It looks like you have the Veta novaclient extension installed correctly, but not the API-side extension (veta-api). The client is properly making the request, but the Nova API server is responding that it doesn't know how to handle the requested action. This means that the Nova API server hasn't been configured with the Veta API extensions (which include the API calls to create/list/remove backup schedules, etc).

Did you follow Step 3 at http://docs.gridcentric.com/veta/installation-source.html ?

Cheers, Tim

edit flag offensive delete publish link more

Comments

Yes i followed all the steps given in http://docs.gridcentric.com/veta/installation-source.html but when i restarted the apache service i got below error, i dont know if because of the below error i am facing veta issue Starting httpd: httpd: apr_sockaddr_info_get() failed for Openstack1 httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName [ OK ]

openstack user ( 2013-12-26 02:19:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2013-12-18 00:49:10 -0500

Seen: 54 times

Last updated: Dec 22 '13