ceph: enable striping on cinder volumes

asked 2016-03-21 14:43:13 -0500

denhackl gravatar image

I am currently struggeling with enabling striping for volumes on a ceph backend. All volumes that are created use an image (primarily ubuntu cloud images (*.img)). If i add an empty volume to cinder, it has striping enabled. I am using OpenStack liberty (via devsteck) and ceph firefly. Everything is configured and installed according to the standard tutorials from the official websites.

Example output via rbd info:
rbd image 'volume-59076e19-416e-4ede-bf96-8424ca325aae': size 4096 MB in 128 objects order 25 (32768 kB objects) block_name_prefix: rbd_data.1c95a62ae8944a format: 2 features: layering

Glance images on the other hand have striping enabled.


The ceph configuration file:

[global]
fsid = ea662a22-d11d-45a3-9b6c-8570bb9e935c
mon_initial_members = t11
mon_host = 192.168.0.11
auth_cluster_required = cephx
auth_service_required = cephx
auth_client_required = cephx
filestore_xattr_use_omap = true
osd_pool_default_min_size = 2
osd_pool_default_size = 2
osd_pool_default_pg_num = 32
osd_pool_default_pgp_num = 32
rbd_default_features = 2
rbd_default_format = 2

[osd]
osd_journal_size = 512
[mon.a]
host = t11
mon_addr = 192.168.0.11:6789
[osd.0]
host =t11
[osd.1]
host = t12
[osd.2]
host = t24

The rbd_default entries do not seem to have an effect. Changing from Format 2 to 1 does not result in any changes.


The relevant cinder.conf entries

[rbd]
volume_driver=cinder.volume.drivers.rbd.RBDDriver
rbd_pool=volumes
rbd_ceph_conf=/etc/ceph/ceph.conf
rbd_flatten_volume_from_snapshot=false
rbd_max_clone_depth=5
glance_api_version=2
rbd_user=cinder
rbd_secret_uuid=XXXXXXXXXXXXXXXXXXXXXXXX
rbd_store_chunk_size = 32

edit retag flag offensive close merge delete