Ask Your Question
1

Resize is ignored

asked 2016-03-21 10:07:04 -0500

raimonbosch gravatar image

updated 2016-03-23 10:35:27 -0500

Hi,

We have found some cases where api call to resize returns a 202 http://developer.openstack.org/api-ref-compute-v2.1.html#resize but it does nothing. In this cases seems like the resize is scheduled, but it is never performed. So the machine keeps in ACTIVE state and no vertical scalability is performed. The easiest way to reproduce the error is by performing a scale down operation i.e. from m1.small to m1.tiny.

Is this a known issue?

This happens with 2014.1.5 (Icehouse) version. The logs don't show any errors aside from some WARNINGS on nova-scheduler.log.

Thanks in advance,

edit retag flag offensive close merge delete

Comments

I will reformulate my question: If the API answers 202 and the resize is not done, how can I debug errors on resize operation?

raimonbosch gravatar imageraimonbosch ( 2016-03-21 10:23:32 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-03-23 10:33:10 -0500

raimonbosch gravatar image

updated 2016-03-23 10:34:19 -0500

The problem was on the way we were deploying our virtual machines. For some reason we were using "nova" as default availability zone in a cluster that didn't have a "nova" availability zone.

So for instance if you deploy a VM in a hostname named server01, you would deploy as availabilityZone="nova:server01". That somehow was causing the problem but not at the moment of deploy, but at the moment of resize. Once I solved the problem by passing its proper availability zone to each node i.e. availabilityZone="availabilityZone01:sever01" the problem was gone.

It was useful to use tcpdump to track the activity of OpenStack's API and check what was really being sent there.

edit flag offensive delete link more
0

answered 2016-03-23 00:17:59 -0500

Vinoth gravatar image

updated 2016-03-23 00:18:41 -0500

Hi,

This could be due to the default settings that don't allow resizing the VM within the same host. So add the below lines in /etc/nova/nova.conf file in compute node.

allow_resize_to_same_host=True

Then Restart all the nova service in the controller and compute node.

Thanks,

Vinoth

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-03-21 10:07:04 -0500

Seen: 175 times

Last updated: Mar 23 '16