Ask Your Question
0

packstack - how to reconfigure br-ex ?

asked 2013-12-17 20:11:57 -0500

marafa gravatar image

updated 2013-12-18 15:37:27 -0500

packstack --allinone --nagios-install=n --mysql-pw=password --ntp-servers=0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org --os-swift-install=y --provision-demo-floatrange=192.168.0.0/24 --keystone-demo-passwd=password

the above is the command i run to install packstack. however, the side effect is that packstack configured br-ex to use 192.168.0.1 which is my gateway's ip.

the question is how do i reconfigure br-ex? i cant find a configuration file in /etc/sysconfig/network-scripts/. a reboot will restore the configuration from somewhere. but where?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-12-18 15:09:38 -0500

larsks gravatar image

updated 2013-12-18 15:10:47 -0500

This document discusses using RDO with an existing network. At a high level, you'll create a network configuration file for br-ex, give it the ip address you're currently using on your primary network interface, and make your primary interface part of br-ex.

If this isn't what you want to do (that is, if you wish you had not used that ip range), you will probably need to delete your public network (neutron net-delete ...) and re-create it with a new range (you'll also need to clear and reset your router's gateway via neutron router-gateway-clear and neutron router-gateway-set).

edit flag offensive delete link more

Comments

@larsk thanks but my problem is br-ex is configured by packstack and i need to reconfigure it. packstack automatically gives br-ex the first ip in the public range

marafa gravatar imagemarafa ( 2013-12-18 15:41:21 -0500 )edit

Yes, I realize that. The document to which I linked describes how to avoid this.

larsks gravatar imagelarsks ( 2013-12-18 15:49:11 -0500 )edit
0

answered 2013-12-18 16:17:42 -0500

marafa gravatar image

@larsk the document states after packstack --allinone reconfigure br-ex by following steps .. etc however, this is like a chicken and egg problem. coz of the duplicate ip issue created by packstack i cant access the openstack box.

edit flag offensive delete link more

Comments

You will obviously need some sort of access to the OpenStack box in order to correct this problem. As the RDO documentation suggests, if you want to use an existing network you're best bet is to *not* have packstack configure the bridge and do it manually once things are up.

larsks gravatar imagelarsks ( 2013-12-18 17:02:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-17 20:11:57 -0500

Seen: 1,359 times

Last updated: Dec 18 '13