My OpenStack stops working after reboot system just after install

asked 2016-03-16 18:29:23 -0500

C Magno gravatar image

updated 2016-03-22 17:49:50 -0500

As I asked here: http://stackoverflow.com/questions/36043976/my-openstack-stops-working-after-reboot-system-just-after-install (http://stackoverflow.com/questions/36...)

My OpenStack stops working after I do the first reboot on the host machine after install. While I not reboot, all works fine.

Apart the Neutron problem, this error happen anyway since my first attempt I not install Neutron.

EDIT: Forgot to say: I'm using Liberty.

EDIT TO SHOW LOGS:

horizon_error.log ( just a relevant fragment )

2016-03-16 18:15:01.945721     raise exceptions.ConnectionFailed(reason=e)
2016-03-16 18:15:01.945724 ConnectionFailed: Connection to neutron failed: HTTPConnectionPool(host='192.168.25.7', port=9696): Max retries exceeded with url: //v2.0/extensions.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f11050e8d90>: Failed to establish a new connection: [Errno 111] Connection refused',))
2016-03-16 18:15:33.803207 Recoverable error: Connection to neutron failed: HTTPConnectionPool(host='192.168.25.7', port=9696): Max retries exceeded with url: //v2.0/extensions.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f1104e98cd0>: Failed to establish a new connection: [Errno 111] Connection refused',))
2016-03-16 18:15:33.806691 REQ: curl -g -i 'http://192.168.25.7:8774/v2.1/50ce883a8f4d46e7b6e9005f2b24e075/os-services' -X GET -H "Accept: application/json" -H "User-Agent: python-novaclient" -H "X-Auth-Project-Id: 50ce883a8f4d46e7b6e9005f2b24e075" -H "X-Auth-Token: {SHA1}3dfa41355227ddb9720b2ec88debecc347aec2c9"
2016-03-16 18:15:33.809259 Recoverable error: HTTPConnectionPool(host='192.168.25.7', port=8774): Max retries exceeded with url: /v2.1/50ce883a8f4d46e7b6e9005f2b24e075/os-services (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f1104e47810>: Failed to establish a new connection: [Errno 111] Connection refused',))
2016-03-16 18:15:33.812160 Recoverable error: Unable to establish connection: HTTPConnectionPool(host='192.168.25.7', port=8776): Max retries exceeded with url: /v2/50ce883a8f4d46e7b6e9005f2b24e075/os-services (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f1104e47cd0>: Failed to establish a new connection: [Errno 111] Connection refused',))
2016-03-16 18:15:33.831452 Call to list enabled services failed. This is likely due to a problem communicating with the Neutron endpoint. Load Balancers panel will not be displayed.
2016-03-16 18:15:33.833730 Call to list enabled services failed. This is likely due to a problem communicating with the Neutron endpoint. Firewalls panel will not be displayed.
2016-03-16 18:15:33.835068 Call to list enabled services failed. This is likely due to a problem communicating with the Neutron endpoint. VPN panel will not be displayed.
2016-03-16 18:15:33.835931 REQ: curl -g -i 'http://192.168.25.7:8774/v2.1/50ce883a8f4d46e7b6e9005f2b24e075/extensions' -X GET -H "Accept: application/json" -H "User-Agent: python-novaclient" -H "X-Auth-Project-Id: 50ce883a8f4d46e7b6e9005f2b24e075" -H "X-Auth-Token: {SHA1}3dfa41355227ddb9720b2ec88debecc347aec2c9"
2016-03-16 18:15:33.836935 Call to list supported extensions failed. This is likely due to a problem communicating with the Nova endpoint. Host Aggregates panel will not be displayed.
2016-03-16 18:15:46.580567 REQ: curl -g -i 'http://192.168.25.7:8774/v2.1/50ce883a8f4d46e7b6e9005f2b24e075/os-hypervisors/detail' -X GET -H "Accept: application/json" -H "User-Agent: python-novaclient" -H "X-Auth-Project-Id: 50ce883a8f4d46e7b6e9005f2b24e075" -H "X-Auth-Token: {SHA1}3dfa41355227ddb9720b2ec88debecc347aec2c9"
2016-03-16 18:15:46 ...
(more)
edit retag flag offensive close merge delete

Comments

you should also mention how you installed openstack. And don't forget to search this site because this may have been answered already.

smaffulli gravatar imagesmaffulli ( 2016-03-16 18:56:04 -0500 )edit

You can investigate what services are running with service --status-all. In addition, you might want to check your `/var/log/[apache|keystone|nova|neutron|etc] directories for logs.

rl_person gravatar imagerl_person ( 2016-03-16 20:12:37 -0500 )edit

Thanks for reply. First try: simple git clone liberty + stack.sh ( no neutron ). Second try, enable_service stuff in localrcto install neutron. Both crashes after boot but works perfectly before boot. I would like to post the link to the tutorial but I can't.

C Magno gravatar imageC Magno ( 2016-03-16 21:28:58 -0500 )edit

I'll check the logs ASAP. By the way: all terminal related commands are asking me to give user and password. I know a simple export to some variables will solve this but I don't know how.

C Magno gravatar imageC Magno ( 2016-03-16 21:30:39 -0500 )edit

@rl_person : there is just the apache2 directory under /var/log. Inside it I can find horizon and keystone logs, no neutron. I'll edit my post to put the logs.

C Magno gravatar imageC Magno ( 2016-03-22 17:13:38 -0500 )edit