Ask Your Question

HA proxy startup error after starting Galera cluster

asked 2016-03-15 14:25:42 -0600

pratap basantia gravatar image

We are using the pacemaker architecture and all the documentation shows that the haproxy in on the same server as the controller node. But when we do that we are not able to start the services and we are facing port conflicts. Below is the snippet of the haproxy config

listen galera_cluster bind balance source option httpchk server controller1 check port 9200 inter 2000 rise 2 fall 5 server controller2 backup check port 9200 inter 2000 rise 2 fall 5

We are getting error as port 3306 is already being used by galera cluster. Is anybody else having similar issue? Or does anybody has a suggestion on how to setup the haproxy on the controller node when the ports are already bound to the same service.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-03-16 13:35:06 -0600

pratap basantia gravatar image

Thank you for your quick reply and please correct me if I'm saying anything wrong as I'm new to Openstack.

I have worked on environment where we have haproxy in the front and the request is served by the backend server but when I read carefully and there was a statement in the documentation which made me believe HAproxy is on the same server as the controller.

Below are few of the statements in the official documentation which I got confused "The common practice is to locate an HAProxy instance on each OpenStack controller in the environment." and "Here is an example /etc/haproxy/haproxy.cfg configuration file. You need a copy of it on each controller node."

Also when I did further research for HA architecture Diagrams. I found the (Sample HA Architecture) which shows that the HAproxy was residing on the controller

Please do correct me if I'm understanding wrong from the documentation and diagram.

edit flag offensive delete link more


I guess that is a good discussion point for the #openstack-ha channel. But regarding the docs you are right, they point out to use HAProxy on the controller nodes.Also I guess that you are running the collapsed architecture

haukebruno gravatar imagehaukebruno ( 2016-03-18 03:46:57 -0600 )edit

please edit bind=<db1-ip> in server.conf

tien86 gravatar imagetien86 ( 2019-11-24 21:48:13 -0600 )edit

answered 2016-03-16 09:39:19 -0600

In a normal deployment the HAProxy Cluster sits in front of your Controllers on dedicated maschines.

It really makes not much sense to install HAProxy on the controllers. I guess you'd missunderstand the documentation a bit.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-03-15 14:25:42 -0600

Seen: 432 times

Last updated: Mar 16 '16