Failed: pip install -r requirements.txt

asked 2016-03-13 06:58:52 -0600

blackwolf gravatar image

Dear all ,

im trying to install SAIO as (

when i Build a development installation of swift by

pip install -r requirements.txt

i got this error:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/", line 122, in main
    status =, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/", line 262, in run
    for req in parse_requirements(filename, finder=finder, options=options, session=session):
  File "/usr/lib/python2.7/dist-packages/pip/", line 1632, in parse_requirements
    req = InstallRequirement.from_line(line, comes_from, prereleases=getattr(options, "pre", None))
  File "/usr/lib/python2.7/dist-packages/pip/", line 173, in from_line
    return cls(req, comes_from, url=url, prereleases=prereleases)
  File "/usr/lib/python2.7/dist-packages/pip/", line 71, in __init__
    req = pkg_resources.Requirement.parse(req)
  File "/usr/lib/python2.7/dist-packages/", line 2667, in parse
    reqs = list(parse_requirements(s))
  File "/usr/lib/python2.7/dist-packages/", line 2605, in parse_requirements
    line, p, specs = scan_list(VERSION,LINE_END,line,p,(1,2),"version spec")
  File "/usr/lib/python2.7/dist-packages/", line 2583, in scan_list
    "Expected ',' or end-of-list in",line,"at",line[p:]
ValueError: ("Expected ',' or end-of-list in", "dnspython3>=1.12.0;python_version<'3.0'", 'at', ";python_version<'3.0'")

Storing debug log for failure in /root/.pip/pip.log

please help me to fix that

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-03-16 06:46:11 -0600

Stany Jude gravatar image

updated 2016-03-16 22:46:02 -0600

Bipin gravatar image

The requirements.txt file located at /swift/requirements.txt. A sample file of requirements.txt is something like this.

'''The order of packages is significant, because pip processes them in the order of appearance. Changing the order has an impact on the overall integration process, which may cause wedges in the gate later.'''

eventlet>=0.17.4  # MIT\n
PyECLib>=1.2.0                          # BSD

Now you open that file and comment out two lines that specify the python requirement.


and retry the operation.

edit flag offensive delete link more

answered 2016-03-17 01:04:01 -0600

3-andrew gravatar image

updated 2016-03-17 01:24:16 -0600

Try upgrading pip inside your virtual environment.

pip install --upgrade pip

Then re-run your command.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-03-13 06:58:52 -0600

Seen: 1,920 times

Last updated: Mar 17 '16