Invalid environment marker: (python version>='3)

asked 2016-03-13 01:18:56 -0500

blackwolf gravatar image

Dear all,

I'm setting Swift all in one based on the guide at: http://docs.openstack.org/developer/swift/development_saio.html#common-dev-section (http://docs.openstack.org/developer/s...)

when i try to do these step

Check out the python-swiftclient repo:

cd $HOME; git clone https://github.com/openstack/python-swiftclient.git
Build a development installation of python-swiftclient:

cd $HOME/python-swiftclient; sudo python setup.py develop; cd -
Ubuntu 12.04 users need to install python-swiftclient’s dependencies before the installation of python-swiftclient. This is due to a bug in an older version of setup tools:

cd $HOME/python-swiftclient; sudo pip install -r requirements.txt; sudo python setup.py develop; cd -

i got a problem :

error in setup command: Invalid environment marker python version>=3.0

i used the ubuntu server 14.04. please help me to fix that

edit retag flag offensive close merge delete