Open vSwitch Issue

asked 2016-03-11 10:34:57 -0500

harshavardhan gravatar image

updated 2016-03-12 01:49:44 -0500

Hi there! I have installed OpenStack Liberty on three nodes (Controller,Compute and Network) on Ubuntu 14.04 server. All the bridges related Open vSwitch are down, if i am trying to to bring up the device ( Ifconfig br-ex up), it is changing to State unknown. I am facing this issue in both compute and network node How can i bring up the device? I uninstalled unrestricted firewall. Thanks in advance!

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
5: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
6: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
7: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
9: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
12: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default
edit retag flag offensive close merge delete

Comments

It'd be helpful if neutron server and agent logs are included.

alfredcs@yahoo.com gravatar imagealfredcs@yahoo.com ( 2016-03-11 21:06:14 -0500 )edit

alfredcs@yahoo.com Thanks for replying here are the logs

openvswitch log on compute node openvswitch-agent.log

openvswitch log on network node openvswitch-agent.log

harshavardhan gravatar imageharshavardhan ( 2016-03-12 01:17:52 -0500 )edit

alfredcs@yahoo.com Neutron Server log on controller node neutron-server.log

harshavardhan gravatar imageharshavardhan ( 2016-03-12 01:20:20 -0500 )edit