Liberty deployement with fuel8.0 on HP moonshot

asked 2016-03-11 04:29:06 -0500

gdupont gravatar image

Hi, We're currently trying to deploy liberty on an HP moonshot appliances (some kind of new dense blade enclosure). It worked well last year with Kilo using packstack but now the installation fail with (apparently) different issues each time.

We tried different setup and configuration options but even the simplest conf (one controller, one compute, no specific services...) failed. The errors in astute logs are not that clear but we've seen several time an issue with netconfig task (see extract hereafter) and we suspect that 1) our 1Gb/s network is not sufficient our 2) the fact that we're only using one NIC with VXLAN is a blocker.

Any advice?

    2016-03-09 13:35:56 INFO    [498] Casting message to Nailgun:
{"method"=>"deploy_resp",
 "args"=>
  {"task_uuid"=>"a428a1b7-5e54-40c9-bc5b-28ab37b1f72d",
   "status"=>"error",
   "error"=>
    "Method granular_deploy. Deployment failed on nodes 23.\nInspect Astute logs for the details"}}
2016-03-09 13:35:56 INFO    [498] Casting message to Nailgun:
{"method"=>"deploy_resp",
 "args"=>
  {"task_uuid"=>"a428a1b7-5e54-40c9-bc5b-28ab37b1f72d",
   "nodes"=>
    [{"uid"=>"23",
      "status"=>"error",
      "error_type"=>"deploy",
      "role"=>"primary-controller",
      "task"=>
       {"priority"=>800,
        "type"=>"puppet",
        "id"=>"netconfig",
        "parameters"=>
         {"puppet_modules"=>"/etc/puppet/modules",
          "puppet_manifest"=>
           "/etc/puppet/modules/osnailyfacter/modular/netconfig/netconfig.pp",
          "timeout"=>3600,
          "cwd"=>"/"},
        "uids"=>["23"]}}]}}
2016-03-09 13:35:56 ERROR   [498] Error running RPC method granular_deploy: Deployment failed on nodes 23, trace: 
["/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:68:in `block (3 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `each_slice'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `block (2 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `block in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:216:in `deploy_cluster'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:52:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/dispatcher.rb:92:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:189:in `dispatch_message'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:146:in `block in dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `call'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `block in each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `each_with_index'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:123:in ...
(more)
edit retag flag offensive close merge delete

Comments

Were you able to solve this issue?

Wasiq Noor gravatar imageWasiq Noor ( 2016-08-25 06:33:00 -0500 )edit