Ask Your Question
0

openstack endpoint keystone not taking hostname.

asked 2016-03-09 09:13:28 -0500

John Bernad gravatar image

So i configure openstack liberty i Centos 7,

I configure the mariadb, keystone, create the keystone DB, grant privileges to keystone user, populate the keystone database. Then as per the document export the environment variables as below,

export OS_TOKEN=0e459616079191ece7b0; export OS_URL=http://controller:35357/v3 export OS_IDENTITY_API_VERSION=3

but when i try to create

openstack service create --name keystone --description "OpenStack Identity" identity

it shows

ERROR HTTP NOT FOUND(401)

so i change the value to ip export OS_URL=http://controller:35357/v3 to export OS_URL=http://192.x.x.x:35357/v3

then it works. i dont know why the openstack service is not taking the hostname.

the /etc/hosts entry is xxxxxxxx xxxxxxxxxx xxxxxxxx xxxxxxxxxx 192.x.x.x controller

please help. i am not getting a clue how to go forward.

edit retag flag offensive close merge delete

Comments

"ping controller". Do u get reply from IP 192.x.x.x?

teju gravatar imageteju ( 2016-03-11 05:20:10 -0500 )edit

yes, the ping controller is working perfectly. i really dont understand why the openstack service does not resolve the hostname.

if we replace the hostname with the specific IP, every things works.

John Bernad gravatar imageJohn Bernad ( 2016-03-11 05:38:47 -0500 )edit

In keystone.conf, what is the value of connection ?

connection = mysql://keystone:KEYSTONE_DBPASS@controller/keystone

Did u specify IP or hostname(controller) as in above line?

teju gravatar imageteju ( 2016-03-11 05:51:44 -0500 )edit

as per the documentation it says controller, so i gave controller itself connection = mysql://keystone:<password>@controller/keystone and this is how i exported the environment variable.

OS_URL=http://controller/35357/v3

John Bernad gravatar imageJohn Bernad ( 2016-03-11 06:10:31 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-16 07:17:01 -0500

John Bernad gravatar image

HI all,

i was so silly to have asked this question, my bad.

The thing was I had set a http_proxy for internet access but did not set a no_proxy for the controller, thus the command $ openstack service create --name keystone --description "OpenStack Identity" identity

was trying to resolve using the proxy which i had totally forgotten. I set a no_proxy and the issue was fixed :)

Thanks teju for trying to help me out.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-03-09 09:13:28 -0500

Seen: 296 times

Last updated: Apr 16 '16