neutron mtu problem with centos 7

asked 2016-03-02 12:02:03 -0500

Marco Marino gravatar image

Hi, I have a production cluster with openstack icehouse release and I'm using openstack-neutron with gre tunnels. Actually I have 12 compute nodes, 2 network nodes and 2 controllers all with centos 6. I'm planning an upgrade and I'd like to upgrade the OS to centos 7 before install the juno release (because from juno there is no support for centos 6). So, I formatted one compute node and then I installed centos 7 and icehouse (yes, I added the EOL repository). All seems to work well, because I can launch a cirrOS instance without problems. However, when I try to launch a centos7 VM, I cannot ssh into it (ssh hangs with SSH2_MSG_KEXINIT sent).I tried to set my MTU to 1300 and all works well (I can connect to ssh), so I think the problem is related to MTU.
First question: Why on centos 6 compute nodes this doesn't happens? On centos 6 nodes I can connect to the vm via ssh (with a client that has an MTU=1500) and then I disable segmentation offloading inside the vm (tx,sg,tso,ufo,gso,gro all to off). Furthermore, If I connect to the vm (on the centos 7 compute node) from a client with an MTU=1300 and I disable tcp offloading inside the vm nothins changes. Is there some kernel parameter that should I enlarge on the physical centos7 node?
Second question: I'm using tcpdump on the physical interface of the compute node used for gre tunnel and packets seems to going out, so I think the problem is on the network node. Could be related to the fact that after the new installation I used same hostname and same ip address? Should I restart the openvswitch network agent and the openvswitch daemon on the network node?
NB: ping works and the MTU between network node and compute nodes is 1500
Thank you

edit retag flag offensive close merge delete