Ask Your Question

linux bridge physical interface mapping

asked 2016-03-02 05:00:00 -0500

lufaxo gravatar image

updated 2016-03-02 05:00:55 -0500

I am running OpenStack Liberty on a three node setup on ubuntu server 14.04 with the official canonical cloudarchive repository.

I've setup an ext-net which is a flat network. And my demo-net uses vxlan(segmention-id: 98).

The problem is that the eth2 on the network node is correctly connected to eth2, but the internal instance-tunnel bridge (vxlan-98) is not.

My linux-bridge configuration (ML2) is.

physical_interface_mappings = vxlan-98:eth1,external:eth2

enable_vxlan = True
local_ip =
l2_population = True

prevent_arp_spoofing = True

enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

brctl shows:

network:~$ brctl show
bridge name     bridge id               STP enabled     interfaces
brq60960441-d6          8000.00e07d8bcd8b       no              eth2
brqbe23e062-4e          8000.0060085c8491       no              

If i manually connect brqbe23e062-4e (instance tunnel bridge) with eth1, everything works fine, so I guess, that the

physical_interface_mappings = vxlan-98:eth1,external:eth2

line is wrong.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-03-10 01:38:04 -0500

lufaxo gravatar image

Found the problem. instead of

physical_interface_mappings = vxlan-98:eth1,external:eth2

it should be

physical_interface_mappings = vxlan:eth1,external:eth2
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-03-02 05:00:00 -0500

Seen: 2,874 times

Last updated: Mar 10 '16