Ask Your Question
1

Mirantis FUEL 8.0 - Cannot deploy successfully

asked 2016-03-02 02:36:23 -0500

tomte76 gravatar image

updated 2016-03-02 22:58:54 -0500

Bipin gravatar image

I want to deploy a Test-Cluster with neutron tunneling and ceph. I did this in the same hardware configuration successful with Mirantis 7. I set up 4 hardware nodes for compute and ceph and one VM for control and telemetry. I set up all VLANs for the default configuration. I can verfiy network successful. I can start the deployment but it always fails during "install openstack 99%" on the controller node. I can see the following errors in the mentioned Astute Log.

2016-03-02 08:07:34 ERROR   [446] Error running RPC method granular_deploy: Deployment failed on nodes 9, trace: 
["/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:68:in `block (3 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `each_slice'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `block (2 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `block in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:216:in `deploy_cluster'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:52:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/dispatcher.rb:92:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:189:in `dispatch_message'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:146:in `block in dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `call'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `block in each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `each_with_index'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:123:in `block in perform_main_job'"]

2016-03-02 08:07:34 ERROR   [446] No more tasks will be executed on the node 9

2016-03-02 08:07:34 ERROR   [446] Task '{"priority"=>1600, "type"=>"puppet", "id"=>"cluster-vrouter", "parameters"=>{"puppet_modules"=>"/etc/puppet/modules", "puppet_manifest"=>"/etc/puppet/modules/osnailyfacter/modular/cluster-vrouter/cluster-vrouter.pp", "timeout"=>3600, "cwd"=>"/"}, "uids"=>["9"]}' failed on node 9

But by now I have no success in tracking it further down. Can anybody help?

Thanks.

edit retag flag offensive close merge delete

Comments

Same here... Fuel 7.0 worked fine, exact configuration, same hardware and network doesn't deploy with Fuel 8.0. I even tried the bare bone configuration just a single controller and it fails.

open4storage gravatar imageopen4storage ( 2016-03-23 09:59:00 -0500 )edit

I am running to the same error..Did you find a solution?

Sofiane68 gravatar imageSofiane68 ( 2016-04-11 05:34:00 -0500 )edit

I've got exactly this issue here! Anyone know the solution?

Willian Andrade gravatar imageWillian Andrade ( 2016-05-31 13:06:07 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-03 02:15:21 -0500

tomte76 gravatar image

updated 2016-03-03 02:43:17 -0500

I made it beyond that point by deploying 3 instead of 1 control nodes. Seems to be related to cluster configuration or quorum . But now I get stuck @this point:

2016-03-03 00:33:56 ERROR [440] Error running RPC method granular_deploy: Failed to execute hook 'updatedb' Puppet run failed. Check puppet logs for details

uids: - '20' - '21' - '17' - '16' - '19' - '18' - '22' parameters: puppet_modules: /etc/puppet/modules puppet_manifest: /etc/puppet/modules/osnailyfacter/modular/ceph/updatedb.pp timeout: 60 cwd: / priority: 100 fail_on_error: true type: puppet id: updatedb , trace: ["/usr/share/gems/gems/astute-8.0.0/lib/astute/nailgun_hooks.rb:64:in block in process'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/nailgun_hooks.rb:26:ineach'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/nailgun_hooks.rb:26:in process'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine/granular_deployment.rb:233:inpost_deployment_actions'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:75:in deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:216:indeploy_cluster'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:52:in granular_deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/dispatcher.rb:92:ingranular_deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:189:in dispatch_message'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:146:inblock in dispatch'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in call'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:inblock in each'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in each'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:ineach'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in each_with_index'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:indispatch'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:123:in `block in perform_main_job'"]

2016-03-03 00:33:56 ERROR [440] 47b522ec-8311-430a-a767-e5043ac2d0a3: puppet timeout error: execution expired

I searched the puppet error logs as mentioned in the message, but I could not find anything related to updatedb there. But I find the puppet-manifest-run on the nodes and it looks ok. Also the file /etc/updatedb.conf is correct on all nodes. It contains /var/lib/ceph.

2016-03-03 00:32:59 +0000 /Stage[main]/Main/Exec[Ensure /var/lib/ceph in the updatedb PRUNEPATH] (info): Starting to evaluat e the resource 2016-03-03 00:32:59 +0000 ExecEnsure /var/lib/ceph in the updatedb PRUNEPATH (debug): Executing check 'tes t ! -f /etc/updatedb.conf || grep 'PRUNEPATHS = *./var/lib/ceph.' /etc/updatedb.conf' 2016-03-03 00:32:59 +0000 Puppet (debug): Executing 'test ! -f /etc/updatedb.conf || grep 'PRUNEPATHS *= *./var/lib/ceph.' /etc/updatedb.conf' 2016-03-03 00:32:59 +0000 ExecEnsure /var/lib/ceph in the updatedb PRUNEPATH (debug): Executing 'sed -i ... (more)

edit flag offensive delete link more

Comments

@tomte76: Were u able to resolve this problem. I am doing exactly the same and after 99% deployment, this error pops up.. Also seems to me u were testing OPNFV release. Is it true?

AB239 gravatar imageAB239 ( 2016-07-12 00:05:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2016-03-02 02:36:23 -0500

Seen: 856 times

Last updated: Mar 03 '16