Ask Your Question
0

creating keystone ERROR: openstack Not Found (HTTP 404) entity liberty debian

asked 2016-03-01 06:09:57 -0500

Vasili B gravatar image

Hi everybody. I have some problems with the subj. Debian jessie, openstack liberty. Using the guide http://docs.openstack.org/liberty/install-guide-ubuntu/keystone-services.html. At first i tried to create new keystone service entity

source keystonerc_adminopenstack service create \
  --name keystone --description "OpenStack Identity" identity

error

usage: openstack service create [-h] [-f {shell,table,value}] [-c COLUMN]
                                [--max-width <integer>] [--prefix PREFIX]
                                [--name <service-name>] [--enable | --disable]
                                <service-type>
openstack service create: error: unrecognized arguments: --description identity

ok, doing it as writen, without description parameter

openstack service create --name keystone --enable identity --debug

Again error appears.

DEBUG: openstackclient.identity.v3.service.CreateService take_action(Namespace(columns=[], disable=False, enable=True, formatter='table', max_width=0, name='keystone', prefix='', type='identity', variables=[]))
DEBUG: keystoneclient.session REQ: curl -i -X POST http://10.0.0.11:35357/v3/services -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: 56a4deb6e9126562ddd6" -d '{"service": {"enabled": true, "type": "identity", "name": "keystone"}}'
INFO: urllib3.connectionpool Starting new HTTP connection (1): 10.0.0.11
DEBUG: urllib3.connectionpool "POST /v3/services HTTP/1.1" 404 287
DEBUG: keystoneclient.session RESP:
DEBUG: keystoneclient.session Request returned failure status: 404
ERROR: openstack Not Found (HTTP 404)

what am i doing wrong? All variables has been exported as decribed in manual. Devstack installs on this OS witout any questions and errors.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-04-21 08:30:45 -0500

Any update to this issue. I have the same error on Ubuntu 14.04 trying to install kilo.

edit flag offensive delete link more
0

answered 2016-03-02 05:04:09 -0500

Vasili B gravatar image

I've recently tried do the same on ubuntu serv trusty and recognized that versions of openstack are different. So i need manual for 2.1.0 openstack.

edit flag offensive delete link more
0

answered 2016-05-25 22:14:28 -0500

Thiha gravatar image

The 404 or Not Found error message is a HTTP standard response code. It happens because web address is not available for some reason.

I was trying openstack redhat installation by following official guide http://docs.openstack.org/mitaka/install-guide-rdo/keystone-services.html (http://docs.openstack.org/mitaka/inst...) and was getting the same issue.

After I restarted apache, the issue is gone.In http://docs.openstack.org/mitaka/install-guide-rdo/keystone-install.html (http://docs.openstack.org/mitaka/inst...) page, it only asks you to start apache after modification of config with "VirtualHost *:35357". But you may have running apache before modification, so please restart apahe and try it again.

Hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-03-01 03:18:45 -0500

Seen: 1,930 times

Last updated: Mar 02 '16