Ask Your Question
0

Could not satisfy constraints for 'pylxd': installation from path or url cannot be constrained to a version

asked 2016-02-29 23:18:15 -0500

beenum gravatar image

I'm trying to install nova-lxd using devstack on ubuntu 15.10 but ./stack.sh fails at a certain point. The end of stack.sh.log is as follows;

/usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 185))
2016-02-29 21:54:48.400 | Installing collected packages: nova-lxd
2016-02-29 21:54:48.401 | Running setup.py develop for nova-lxd
2016-02-29 21:54:49.633 | Successfully installed nova-lxd-13.0.0.0b2.dev115
2016-02-29 21:54:49.858 | Installing test-requirements for /opt/stack/nova-lxd/test-requirements.txt
2016-02-29 21:54:50.443 | Ignoring dnspython3: markers "python_version=='3.4'" don't match your environment
2016-02-29 21:54:50.578 | Ignoring python-ironic-inspector-client: markers "python_version=='3.4'" don't match your environment
2016-02-29 21:54:50.691 | Could not satisfy constraints for 'pylxd': installation from path or url cannot be constrained to a version
2016-02-29 21:54:50.928 | Error on exit

2016-02-29 21:54:51.217 | ovs-ofctl: br-int is not a bridge or a socket
2016-02-29 21:54:51.235 | ovs-ofctl: br-tun is not a bridge or a socket
2016-02-29 21:54:51.269 | ovs-ofctl: br-ex is not a bridge or a socket
2016-02-29 21:54:51.289 | ovs-ofctl: br-int is not a bridge or a socket
2016-02-29 21:54:51.332 | ovs-ofctl: br-tun is not a bridge or a socket
2016-02-29 21:54:51.352 | ovs-ofctl: br-ex is not a bridge or a socket

And used the sample local.conf with little additions as follows;

[[local|localrc]]

ADMIN_PASSWORD=a DATABASE_PASSWORD=a RABBIT_PASSWORD=a SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5

SWIFT_REPLICAS=1

SWIFT_DATA_DIR=$DEST/data

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service q-metering
enable_service neutron

Q_PLUGIN=ml2
Q_AGENT=openvswitch
Q_USE_DEBUG_COMMAND=True
Q_L3_ENABLED=True
Q_L3_ROUTER_PER_TENANT=True
ENABLE_TENANT_TUNNELS=True

enable_plugin nova-lxd https://github.com/lxc/nova-lxd

Any help would really be appreciated :(

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-03-10 03:03:41 -0500

matrohon gravatar image

This issues seems to come from latest pip.

A related bug has been reported to devstack :

https://bugs.launchpad.net/devstack/+bug/1540328 (https://bugs.launchpad.net/devstack/+...)

edit flag offensive delete link more
0

answered 2016-03-15 18:17:05 -0500

dilip gravatar image

updated 2016-03-15 18:17:36 -0500

If you want to run devstack with lxd then comment the all lines from the files where you got the error ex: /opt/stack/nova-lxd/requirements.txt and re run ./stack.sh

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-29 23:17:14 -0500

Seen: 960 times

Last updated: Mar 15 '16