Ask Your Question

devstack: Keystone not listening on 5000 after

asked 2016-02-29 13:30:58 -0500

ICBeter gravatar image

updated 2016-02-29 14:47:09 -0500

I installed devstack in a Virtualbox machine with no problems. I could log into the dashboard and start a cirros instance.

Then I shut everything down with ./ and rebooted the machine. After reboot I executed ./ When I try to log in on the dashboard it shows: Unable to establish connection to keystone endpoint.

The log shows: Unable to establish connection to and a netstat -pan also shows nothing listening on port 5000.

I can start keystone manually with:

/usr/bin/python /usr/local/bin/keystone-all
--config-file /etc/keystone/keystone.conf

But that is just a workaround... Keystone should of course start automatically. What is going wrong here and where could I start looking for the problem?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-02-29 16:19:06 -0500

ICBeter gravatar image

Looks like I found the problem:

./ seems to remove the symlink /etc/apache2/sites-enabled/keystone.conf and ./ does not recreate it. The solution is:

cd /etc/apache2/sites-enabled 
ln -s ../sites-available/keystone.conf

before calling ./

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-02-29 13:30:58 -0500

Seen: 873 times

Last updated: Feb 29 '16