Neutron qrouter default route problem

asked 2013-12-16 19:55:20 -0600

pann1588 gravatar image

updated 2013-12-16 23:11:45 -0600

Hi everyone,

We have a OpenStack deployment of three nodes: controller, network node, and compute node. After installing everything, I created external network and subnet in the "admin" user, and then login with tenant user to create tenant network and subnet. Then I created a router to interconnect the two subnets.

The I tried to ping outside from the VMs we launched but it didn't succeed. I traced ICMP packets and found that it can ping through both two interfaces (internal and external) of the router I created, but not to the external network. Then I used "sudo ip netns exec qroute-xxxx route -n " and found that the default route entry is missing. After I manually added the default route, then the ping went through succssfully. After associating VMs with floating IP, ping the VMs from outside were also successfully.

So, my question is, what is the reason for it, and which module is responsible for configuring the default routing table? What should I do to overcome such issue? Thanks a lot!

Regards, Jianli


Hi larsks,

Thanks a lot for the help. I use the dashboard to create all the networks and didn't use the command line. Shall I do that instead? I followed a tutorial written in Chinese on how to operate dashboard to create external and internal network. The link is: http://www.ustack.com/blog/neutron_intro/ There are screenshots in this tutorial so hopefully you could get a sense of what it is trying to teach. I basically create an external network in admin account, and then login with customer tenant account to create internal network, and then created a router to connect the internal with external.

#neutron net-list: +--------------------------------------+---------+-------------------------------------------------------+ | id | name | subnets | +--------------------------------------+---------+-------------------------------------------------------+ | 69032459-4b0b-49d5-8088-31886c7faa9c | ext-net | 25760bbe-424f-4309-aa89-2afd7541c700 192.168.1.224/27 | | e5f83f9c-e633-4dd5-8021-23a870331784 | conaNet | 4feee8dd-77c4-4602-bdd5-d4121481da5c 10.20.30.0/24 | +--------------------------------------+---------+-------------------------------------------------------+

#neutron router-list: +--------------------------------------+-------------+-----------------------------------------------------------------------------+ | id | name | external_gateway_info | +--------------------------------------+-------------+-----------------------------------------------------------------------------+ | ff25c07b-02ca-41e4-9299-e86593d3fc79 | cona_router | {"network_id": "69032459-4b0b-49d5-8088-31886c7faa9c", "enable_snat": true} | +--------------------------------------+-------------+-----------------------------------------------------------------------------+

#neutron router-port-list : +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+ | id | name | mac_address | fixed_ips | +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+ | 3bf353a2-b3f7-4ff0-b37c-09e1b0f75108 | | fa:16:3e:f3:1f:ec | {"subnet_id": "4feee8dd-77c4-4602-bdd5-d4121481da5c", "ip_address": "10.20.30.1"} | | 5ad09e95-4c9e-4480-95a5-fbf7c2e289cd | | fa:16:3e:37:94:0c | {"subnet_id": "25760bbe-424f-4309-aa89-2afd7541c700", "ip_address": "192.168.1.225"} | +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+

Sorry for the formatting when I pasted it here.

Thanks again! Jianli

edit retag flag offensive close merge delete

Comments

Can you show us the exact commands you used to create your external network and router? How did you attach the router to your internal network? Can you post the output of "neutron net-list", "neutron router-list", and "neutron router-port-list <router_id>"?

larsks gravatar imagelarsks ( 2013-12-16 22:53:52 -0600 )edit

Hi larsks, Thanks a lot. I've just updated the above post to show you related information.

pann1588 gravatar imagepann1588 ( 2013-12-16 23:12:32 -0600 )edit

Problem solved. It looks that the external net CIDR address pool I set had some issue. The original one I used is 192.168.1.224/27 and the reason I selected it is that I tried to avoid any address collision with the existing hosts in the external net. After I changed to 192.168.1.0/24, the default routing entry was created successfully.

pann1588 gravatar imagepann1588 ( 2013-12-17 19:31:57 -0600 )edit