Ask Your Question
0

instances cant not get private network ip address

asked 2016-02-25 17:57:42 -0500

slosh_liuxin gravatar image

Hi, In openstack kilo,all services were fine.But,when i lanuch an instance,i got errors like this in the openvswitch-agent.log:

2016-02-25 14:49:27.315 68239 ERROR neutron.agent.linux.utils [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ]
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'dump-flows', 'br-int', 'table=23']
 Exit code: 1
Stdin:
Stdout:
Stderr: ovs-ofctl: br-int is not a bridge or a socket

 2016-02-25 14:49:27.317 68239 ERROR neutron.agent.common.ovs_lib [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ]   Unable to execute ['ovs-ofctl', 'dump-flows', 'br-int', 'table=23']. Exception:
 Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'dump-flows', 'br-int', 'table=23']
 Exit code: 1
 Stdin:
 Stdout:
 Stderr: ovs-ofctl: br-int is not a bridge or a socket
 2016-02-25 15:01:22.006 68239 ERROR neutron.agent.linux.ovsdb_monitor [-] Error received from ovsdb monitor: ovsdb-client: unix:/var/run/openvswitch/db.sock: receive failed (End of file)
 2016-02-25 15:01:23.005 68239 WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ] OVS is restarted. OVSNeutronAgent will reset bridges and recover ports.






  And also i fine some errors in the /var/log/messages like this:
  Feb 26 07:45:03 compute01 kernel: qbr64549e78-56: port 2(tap64549e78-56) entered disabled state
  Feb 26 07:45:03 compute01 kernel: device tap64549e78-56 left promiscuous mode
  Feb 26 07:45:03 compute01 kernel: qbr64549e78-56: port 2(tap64549e78-56) entered disabled state
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <info>  (tap64549e78-56): device state change: activated -> unmanaged (reason 'removed') [100 10 36]
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <info>  (tap64549e78-56): deactivating device (reason 'removed') [36]
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <warn>  (qbr64549e78-56): failed to detach bridge port tap64549e78-56
  Feb 26 07:45:03 compute01 dbus[3025]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'


 I donn't find where is my mistake.So,i need help for solve the errors.....Thans for any help!
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-25 19:07:45 -0500

Mohit gravatar image

Looks like openvswitch bridge is not setup correctly , You can follow the section To configure the Open vSwitch (OVS) serviceat http://docs.openstack.org/kilo/instal... Similar doc section 2. Openvswitch Configurationat http://neharawat.in/centos-openstack-...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-25 17:57:42 -0500

Seen: 269 times

Last updated: Feb 25 '16