Ask Your Question
0

Openstack Swift error

asked 2016-02-24 07:46:31 -0500

Aun gravatar image

updated 2016-02-24 15:56:11 -0500

I have setup swift object storage on my openstack setup. But when i checked swift stat from controller/proxy node, here is what it displays. +++

[root@controller-hostname swift]# swift stat
Account HEAD failed: http://controller-hostname:8080/v1/AUTH_64cae0b8b2644cdc9b01aa5ff21646c8 401 Unauthorized

+++

here is my proxy server configuration.

===

[DEFAULT]

bind_port = 8080

swift_dir = /etc/swift

user = swift

[pipeline:main]

pipeline = catch_errors gatekeeper healthcheck proxy-logging cache container_sync bulk tempurl ratelimit tempauth container-quotas account-quotas slo dlo proxy-logging proxy-server

[filter:authtoken]
paste.filter_factory = keystonemiddleware.auth_token:filter_factory

auth_uri = http://controller-hostname:5000

auth_url = http://controller-hostname:35357

auth_plugin = password

project_domain_id = default

user_domain_id = default

project_name = service

username = swift

password = openstack

delay_auth_decision = true

==

/var/log/messages are not reporting any related errors. any help with be highly appreciated, i googled a lot of discussion links but non seems to help my case. Thanks guys.

Regards Aun

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-02-24 20:46:21 -0500

Mohit gravatar image

Update auth_uri = http://controller-hostname:5000 to auth_uri = http://controller-hostname:5000:/v2.0 restart the swift services and check.

edit flag offensive delete link more

Comments

Thanks mohit, it resolved my issue.

Aun gravatar imageAun ( 2016-02-25 01:21:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-24 07:46:31 -0500

Seen: 155 times

Last updated: Feb 24 '16