Ask Your Question
0

ceilometer statistics -m image.download -p 60 show nothing

asked 2016-02-24 05:26:11 -0600

chansonzhang gravatar image

updated 2016-02-24 15:57:51 -0600

I followed this guide, when I run ceilometer meter-listafter glance image-download "cirros-0.3.2-x86_64" > cirros.img,i haven't see image.download and image.serve in the output. And as the title mentioned,ceilometer statistics -m image.download -p 60only show a empty table as follow:

+--------+--------------+------------+-----+-----+-----+-----+-------+----------+----------------+--------------+
| Period | Period Start | Period End | Max | Min | Avg | Sum | Count | Duration | Duration Start | Duration End |
+--------+--------------+------------+-----+-----+-----+-----+-------+----------+----------------+--------------+
+--------+--------------+------------+-----+-----+-----+-----+-------+----------+----------------+--------------+
edit retag flag offensive close merge delete

Comments

@chansonzhang, which version of OpenStack U r using? Have U configured notificaitons for Glance? Do U have a default pipeline.yaml or customized one?

yprokule gravatar imageyprokule ( 2016-02-25 04:44:50 -0600 )edit

I use icehouse, and i configured notifications for glance in /etc/glance/glance-api.conf with notification_driver = messaging rpc_backend = qpid as to pipeline.yaml or customized one, i am not very understand, i am a new man

chansonzhang gravatar imagechansonzhang ( 2016-02-26 02:54:26 -0600 )edit

Just to double check - do U have all qpid related stuff configured(host/port/credentials) both in ceilometer.conf and glance-api.conf?

Regarding pipeline.yaml - have U done some changes to it or it is the default one?

yprokule gravatar imageyprokule ( 2016-02-28 23:44:01 -0600 )edit

The qpid stuff you mentioned have all been setted both in ceilometer.conf and glance-api.conf, and the pipeline.yaml is the default one, i haven't touch that.

chansonzhang gravatar imagechansonzhang ( 2016-02-29 02:08:56 -0600 )edit

Could U check if notifications are reaching your qpid instance? I'm not familiar with it so cannot help with exact commands.

yprokule gravatar imageyprokule ( 2016-03-02 01:01:10 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-03-05 21:18:38 -0600

chansonzhang gravatar image

updated 2016-11-18 01:56:37 -0600

I finally solved this problem by chance, i add a linecontrol_exchange=glance in the file /etc/glance/glance-api.conf. I find in /etc/ceilometer/ceilometer.conf there is a line like glance_control_exchange= glance, which may be corresponding with the line i added. though the line in ceilometer.conf have been commented, but glance may be its default value.

edit flag offensive delete link more

Comments

Glad to hear U've managed to get notifications passing

yprokule gravatar imageyprokule ( 2016-03-07 01:08:28 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-24 05:26:11 -0600

Seen: 183 times

Last updated: Nov 18 '16