Ask Your Question
0

Launching an Instance [closed]

asked 2016-02-23 10:21:03 -0500

harshavardhan gravatar image

Hi all! I'm newbie to OpenStack. I have installed OpenStack Liberty with one controller node and one compute node. I followed OpenStack docs while installtion. While launching an instance i am getting an error

ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible. <class 'keystoneclient.exceptions.BadRequest'> (HTTP 500) (Request-ID: req-90617730-493a-4974-93a6-a68642d5ace7) . In nova api log file i found this info will be useful for you. Please help me with the issue. Thanks in advance.

Expecting to find username or userId in passwordCredentials - the server could not comply with the request since it is either malformed or otherwise incorrect. The client is assumed to be in error. (HTTP 400) (Request-ID: req-da44b5ce-65f0-4cf8-9f7a-8097fbeb1412)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by harshavardhan
close date 2016-02-24 20:16:10.401006

1 answer

Sort by ยป oldest newest most voted
2

answered 2016-02-24 01:14:51 -0500

Aun gravatar image

updated 2016-02-24 16:04:22 -0500

Have double checked that nova.conf is properly configured? specially for following parameters.

network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.NeutronLinuxBridgeInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
edit flag offensive delete link more

Comments

Thank You @Aun for your time. Problem got resolved.

harshavardhan gravatar imageharshavardhan ( 2016-02-24 20:15:20 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-23 10:21:03 -0500

Seen: 354 times

Last updated: Feb 24 '16