Ask Your Question
0

NoVNC connect error 1006

asked 2016-02-22 19:32:23 -0500

Thomas Krause gravatar image

updated 2016-02-24 16:14:08 -0500

On a brand new OpenStack install (Liberty) we're receiving a 1006 error when trying to access the console of a VM through NoVNC. When we access it a token is generated and listed in the config file but it seems that when the client tries to access it, there is a write delay and it does not connect. However, if you open the same URL in another page or refresh the iframe it immediately connects. Seems to me that there is a race condition occurring here between writing the token and reading it. While it does work, it is extremely irritating to use does anyone have a fix for this?

Before Refresh

/var/log/nova/nova-novncproxy.log:

2016-02-23 01:27:55.639 20827 INFO oslo.messaging._drivers.impl_rabbit [req-9a20b179-b226-4d93-a496-76b95540f325 - - - - -] Connecting to AMQP server on controller:5672
2016-02-23 01:27:55.648 20827 INFO oslo.messaging._drivers.impl_rabbit [req-9a20b179-b226-4d93-a496-76b95540f325 - - - - -] Connected to AMQP server on controller:5672
2016-02-23 01:27:55.678 20827 INFO oslo.messaging._drivers.impl_rabbit [req-9a20b179-b226-4d93-a496-76b95540f325 - - - - -] Connecting to AMQP server on controller:5672
2016-02-23 01:27:55.691 20827 INFO oslo.messaging._drivers.impl_rabbit [req-9a20b179-b226-4d93-a496-76b95540f325 - - - - -] Connected to AMQP server on controller:5672
2016-02-23 01:27:55.700 20827 INFO nova.console.websocketproxy [req-9a20b179-b226-4d93-a496-76b95540f325 - - - - -] handler exception: The token '0a794a36-7c48-409e-bca8-936e6203d170' is invalid or has expired

After Refresh

/var/log/nova/nova-novncproxy.log:

2016-02-23 01:28:40.362 20840 INFO oslo.messaging._drivers.impl_rabbit [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -] Connecting to AMQP server on controller:5672
2016-02-23 01:28:40.376 20840 INFO oslo.messaging._drivers.impl_rabbit [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -] Connected to AMQP server on controller:5672
2016-02-23 01:28:40.399 20840 INFO oslo.messaging._drivers.impl_rabbit [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -] Connecting to AMQP server on controller:5672
2016-02-23 01:28:40.408 20840 INFO oslo.messaging._drivers.impl_rabbit [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -] Connected to AMQP server on controller:5672
2016-02-23 01:28:40.481 20840 INFO nova.console.websocketproxy [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -]  741: connect info: {u'instance_uuid': u'bd970307-9a90-4d4d-8b9a-a4a0b250d589', u'internal_access_path': None, u'last_activity_at': 1456190874.85105, u'console_type': u'novnc', u'host': u'10.3.1.13', u'token': u'0a794a36-7c48-409e-bca8-936e6203d170', u'access_url': u'http://controller:6080/vnc_auto.html?token=0a794a36-7c48-409e-bca8-936e6203d170', u'port': u'5900'}
2016-02-23 01:28:40.482 20840 INFO nova.console.websocketproxy [req-b7e4dc7b-9533-44d4-9d56-45d3cf21b5d6 - - - - -]  741: connecting to: 10.3.1.13:5900

Infrastructure:

  1. Controller - 10.3.1.1
  2. Compute3 (node where the instance is running) - 10.3.1.13
  3. Load Balancer - 10.3.1.10

Thanks,

edit retag flag offensive close merge delete

Comments

check if this can help you.

Syed Awais Ali gravatar imageSyed Awais Ali ( 2016-02-23 07:01:21 -0500 )edit

Are your nodes synced in time with a NTP server?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-02-24 16:14:56 -0500 )edit

@Syed That documents has to do with setting up NoVNC from the beginning which as I said in my question is working. There just seems to be a delay in the token.

@Eduardo Yes, they are all using the same NTP server with ntpd. I understand the documentation recommends Chrony but it shouldn't matter.

Thomas Krause gravatar imageThomas Krause ( 2016-02-27 10:35:16 -0500 )edit

You need to configure memcached to your nova-consoleauth services. Only one service can be running at the same time. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-05-10 11:34:22 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-05-10 11:48:11 -0500

Hi,

When running a multi node environment with HA between two or more controller nodes(or controller plane service nodes), nova consoleauth service must be configured with memcached.

If not, no more than one consoleauth service can be running in active state, since it need to save the state of the sessions. When memcached is not used, you can check that can connect to the vnc console only a few times when you refresh the page. If that occurs means that the connection is handled by the consoleauth service that currently is issuing sessions.

To solve your issue, configure memcached as backend to nova-consoleauth service.

To solve your issue add this line to nova.conf:

memcached_servers = 192.168.100.2:11211,192.168.100.3:11211

This should work to solve your issue.

Regards

edit flag offensive delete link more
0

answered 2016-05-09 09:14:42 -0500

victornc83 gravatar image

Hi,

Do you get a solution? I have the same issue, I think it could be related with LB configuration. I'm using HA proxy.

Any suggestion?

Thanks! Regards.

edit flag offensive delete link more

Comments

1

If you are using haproxy to various controller nodes. Only one nova-consouleauth service can be running at the same time unless you configure memcached to the nova-consoleauth service.

Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-05-10 11:32:47 -0500 )edit

Great! Really thank you. I've configured an external memcache server and now it's working properly. Thank you so much.

victornc83 gravatar imagevictornc83 ( 2016-05-11 09:33:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-22 19:32:23 -0500

Seen: 3,762 times

Last updated: May 10 '16