Ask Your Question
1

linux bridge not forwarding packets to tap interface

asked 2016-02-19 08:15:45 -0500

malascom gravatar image

updated 2016-02-20 11:25:36 -0500

I have installed Liberty version of openstack. I get problem when a dhcp request i send form the instance . I create a FLAT network and i boot the instance, the problem is that the DHCPDISCOVER reaches the DHCP server on the controller, the DHCP server generates DHCPOFFER and the DHCPOFFER is propagated to the compute node. When the packet is at the linux bridge of the COMPUTE NODE, the packet is sent towards eth0 and not the Tap interface on which the instance is .

As you can notice in the $brctl showmacs command there are three entries for the instance:

  2     fa:16:3e:4d:41:d6       no               132.30
  1     fe:16:3e:4d:41:d6       yes                0.00
  1     fe:16:3e:4d:41:d6       yes                0.00

the first one is saying that is not local and he is sending the packet to PORT 2 on which is eth0... how do i fix this in the linux bridge ?

Can somebody help me how to make the linux bridge forward the packet towards TAP interface...

I can see the DHCPOFFER packet on eth0 interface , then i can see it in the linux bridge and then again in the eth0.. the packet is sent back

Here is my configuration on compute node:

ifconfig on the compute node:

root@compute:/home/opencontrolnode01# ifconfig
brqa7ecec51-b9 Link encap:Ethernet  HWaddr 00:0c:29:a0:61:0a
          inet addr:10.70.70.7  Bcast:10.70.70.255  Mask:255.255.255.0
          inet6 addr: fe80::508b:a1ff:fe44:c9c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1442 (1.4 KB)  TX bytes:1564 (1.5 KB)

eth0      Link encap:Ethernet  HWaddr 00:0c:29:a0:61:0a
          inet6 addr: fe80::20c:29ff:fea0:610a/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:285454 errors:0 dropped:2 overruns:0 frame:0
          TX packets:298 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:261167472 (261.1 MB)  TX bytes:47022 (47.0 KB)

eth1      Link encap:Ethernet  HWaddr 00:0c:29:a0:61:14
          inet addr:10.71.71.7  Bcast:10.71.71.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fea0:6114/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1814 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1959 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:587718 (587.7 KB)  TX bytes:693827 (693.8 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3209 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3209 ...
(more)
edit retag flag offensive close merge delete

Comments

1

eth0 oui is 00:0c:29 - if this is running on vmware, then you will need to go into vmware and make the vnic promiscous.

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-02-20 10:04:39 -0500 )edit

i am runing on vbox but anyway i will set up the interfaces to promiscous. Just one question, is it OK that my eth0 in vbox is set up as bridged_adapter and my eth1 is as host only adapter or i need to change that ?

malascom gravatar imagemalascom ( 2016-02-20 10:46:00 -0500 )edit

thank you a lot ... That was the problem, i set up the network interface eth0 to promiscous from Virtual Box Menu and now is working :D thanks one more time

malascom gravatar imagemalascom ( 2016-02-20 11:21:29 -0500 )edit

darragh-oreilly do you know how to set up vnic to promiscous from vmware ?

malascom gravatar imagemalascom ( 2016-02-22 08:56:12 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-19 11:11:45 -0500

soumitrakarmakar gravatar image

Can you share your ml2_conf.in and linux-bridge-agent.conf file on the controller , nova, neutron nodes.

edit flag offensive delete link more

Comments

i just added the files in the description. i just noticed that in $brctl showmacs command there are three entries for the instance: 2 fa:16:3e:4d:41:d6 no 132.30 1 fe:16:3e:4d:41:d6 yes 0.00 1 fe:16:3e:4d:41:d6 yes

malascom gravatar imagemalascom ( 2016-02-19 14:44:55 -0500 )edit

the problem is there do you have any idea how to fix this ? because the bridge is looking in the table, he sees the first entrance that says port 2 for fa:16:3e:4d:41:d6 and he sends back to eth0

malascom gravatar imagemalascom ( 2016-02-19 14:46:14 -0500 )edit

Seems you have used to the Networking option one provider network, I suggest configure your network using option 2 and you should be good with your deployment. "http://docs.openstack.org/liberty/install-guide-ubuntu/neutron-controller-install.html#neutron-controller-metadata-agent"

soumitrakarmakar gravatar imagesoumitrakarmakar ( 2016-02-20 01:22:12 -0500 )edit

ok i will tru option 2 and i let you know how it goes

malascom gravatar imagemalascom ( 2016-02-20 03:11:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-19 08:15:45 -0500

Seen: 2,248 times

Last updated: Feb 20 '16