Ask Your Question
0

tempest initialization fails while devstack installation.

asked 2016-02-18 03:30:41 -0500

brij gravatar image

updated 2016-02-18 15:11:09 -0500

Hi All,

I have been trying to install devstack on my Ubuntu machine but while initializing tempest I am getting the below error. I have tried for 4-5 times but still facing the same issue.

2016-02-18 08:17:00.403 | venv create: /opt/stack/new/tempest/.tox/venv
2016-02-18 08:17:10.731 | venv installdeps: -r/opt/stack/new/tempest/requirements.txt, -r/opt/stack/new/tempest/test-requirements.txt
2016-02-18 08:17:48.313 | ERROR: invocation failed (exit code 1), logfile: /opt/stack/new/tempest/.tox/venv/log/venv-1.log
2016-02-18 08:17:48.314 | ERROR: actionid: venv
2016-02-18 08:17:48.314 | msg: getenv
2016-02-18 08:17:48.314 | cmdargs: [local('/opt/stack/new/tempest/.tox/venv/bin/pip'), 'install', '-U', '-r/opt/stack/new/tempest/requirements.txt', '-r/opt/stack/new/tempest/test-requirements.txt']
2016-02-18 08:17:48.314 | env: {'LOGNAME': 'stack', 'USER': 'stack', 'OS_REGION_NAME': 'RegionOne', 'OS_PROJECT_NAME': 'admin', 'PS4': '+ ${BASH_SOURCE:-}:${FUNCNAME[0]:-}:L${LINENO:-}:   ', 'PATH': '/opt/stack/new/tempest/.tox/venv/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/sbin:/usr/sbin:/usr/local/sbin:/usr/sbin:/sbin', 'OS_NO_CACHE': 'True', 'TERM': 'unknown', 'SHELL': '/bin/bash', 'OS_IDENTITY_API_VERSION': '3', 'NEUTRON_TEST_CONFIG_FILE': '/etc/neutron/debug.ini', 'USE_PYTHON3': 'False', 'PYTHON3_VERSION': '3.4', 'PYTHONHASHSEED': '299230788', 'SUDO_USER': 'jenkins', 'HOME': '/opt/stack/new', 'USERNAME': 'stack', 'OS_USERNAME': 'admin', 'SUDO_UID': '1001', '_STDBUF_O': 'L', 'OS_USER_DOMAIN_ID': 'default', 'PWD': '/opt/stack/new/tempest', 'PYTHON2_VERSION': '2.7', 'OS_PASSWORD': 'secretadmin', 'LC_ALL': 'C', '_': '/usr/local/bin/tox', 'LD_PRELOAD': '/usr/lib/coreutils/libstdbuf.so', 'SUDO_COMMAND': '/usr/bin/stdbuf -oL -eL ./stack.sh', 'SUDO_GID': '1002', 'VIRTUAL_ENV': '/opt/stack/new/tempest/.tox/venv', 'OS_PROJECT_DOMAIN_ID': 'default', '_STDBUF_E': 'L', 'OLDPWD': '/opt/stack/new/devstack', 'SHLVL': '1', 'OS_AUTH_URL': 'http://127.0.0.1:35357', 'OS_TEST_PATH': './tempest/tests', 'MAIL': '/var/mail/stack'}
2016-02-18 08:17:48.314 | 
2016-02-18 08:17:48.314 | Collecting pbr>=1.6 (from -r /opt/stack/new/tempest/requirements.txt (line 4))
2016-02-18 08:17:48.314 | /opt/stack/new/tempest/.tox/venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
2016-02-18 08:17:48.314 |   SNIMissingWarning
2016-02-18 08:17:48.314 | /opt/stack/new/tempest/.tox/venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
2016-02-18 08:17:48.314 |   InsecurePlatformWarning
2016-02-18 08:17:48.314 |   Using cached pbr-1.8.1-py2.py3-none-any.whl
2016-02-18 08:17:48.314 | Collecting cliff!=1.16.0,>=1.15.0 (from -r /opt/stack/new/tempest/requirements.txt ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-03-02 21:27:23 -0500

JohnnyChou gravatar image

updated 2016-03-03 20:57:06 -0500

I had the same issue, also.

Here is my workaround about this:

The default pypi mirror is no longer in use. You need to update the content of "pydistutils.cfg" to be the same as this:

https://github.com/openstack-infra/system-config/blob/master/modules/openstack_project/files/pydistutils.cfg (https://github.com/openstack-infra/sy...)

change

  • index_url = http://pypi.dfw.openstack.org/simple

to

  • index_url = http://mirror.dfw.rax.openstack.org/pypi/simple (http://mirror.dfw.rax.openstack.org/p...)
edit flag offensive delete link more

Comments

can this be changed in setup.cfg instead? then we run the ./stack.sh installation script file

聪明健康 gravatar image聪明健康 ( 2016-03-04 01:04:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-18 03:30:41 -0500

Seen: 1,497 times

Last updated: Mar 03 '16