manila-manage db sync is throwing error in ubuntu for liberty release?

asked 2016-02-16 07:10:12 -0500

soumitrakarmakar gravatar image

updated 2016-02-18 23:24:00 -0500

Hi, I am trying to implement the manila feature in openstack liberty release, but the manila-manage db sync command is throwing error. How to do I update the manila DB in ubuntu for manila.

"root@controller:/home/kilo/liberty_controller# su -s /bin/bash manila -c "manila-manage db sync" 2016-02-19 10:53:06.799 7475 INFO alembic.runtime.migration [-] Context impl SQLiteImpl. 2016-02-19 10:53:06.800 7475 INFO alembic.runtime.migration [-] Will assume non-transactional DDL. 2016-02-19 10:53:06.920 7475 INFO alembic.runtime.migration [-] Running upgrade -> 162a3e673105, manila_init 2016-02-19 10:53:07.052 7475 INFO alembic.runtime.migration [-] Running upgrade 162a3e673105 -> 211836bf835c, add access level 2016-02-19 10:53:07.056 7475 INFO alembic.runtime.migration [-] Running upgrade 211836bf835c -> 38e632621e5a, change volume_type to share_type 2016-02-19 10:53:07.064 7475 INFO 38e632621e5a_change_volume_type_to_share_type_py [-] Renaming column name shares.volume_type_id to shares.share_type.id 2016-02-19 10:53:07.066 7475 CRITICAL manila [-] OperationalError: (sqlite3.OperationalError) near "ALTER": syntax error [SQL: u'ALTER TABLE shares ALTER COLUMN volume_type_id TYPE VARCHAR(36)'] 2016-02-19 10:53:07.066 7475 ERROR manila Traceback (most recent call last): 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/bin/manila-manage", line 10, in <module> 2016-02-19 10:53:07.066 7475 ERROR manila sys.exit(main()) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/manila/cmd/manage.py", line 454, in main 2016-02-19 10:53:07.066 7475 ERROR manila fn(fn_args) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/manila/cmd/manage.py", line 213, in sync 2016-02-19 10:53:07.066 7475 ERROR manila return migration.upgrade(version) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/manila/db/migration.py", line 28, in upgrade 2016-02-19 10:53:07.066 7475 ERROR manila return IMPL.upgrade(version) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/manila/db/migrations/alembic/migration.py", line 51, in upgrade 2016-02-19 10:53:07.066 7475 ERROR manila return alembic.command.upgrade(_alembic_config(), revision or 'head') 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/alembic/command.py", line 174, in upgrade 2016-02-19 10:53:07.066 7475 ERROR manila script.run_env() 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/alembic/script/base.py", line 397, in run_env 2016-02-19 10:53:07.066 7475 ERROR manila util.load_python_file(self.dir, 'env.py') 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/alembic/util/pyfiles.py", line 81, in load_python_file 2016-02-19 10:53:07.066 7475 ERROR manila module = load_module_py(module_id, path) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/alembic/util/compat.py", line 79, in load_module_py 2016-02-19 10:53:07.066 7475 ERROR manila mod = imp.load_source(module_id, path, fp) 2016-02-19 10:53:07.066 7475 ERROR manila File "/usr/lib/python2.7/dist-packages/manila/db ... (more)

edit retag flag offensive close merge delete

Comments

Please, paste error output. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-02-18 15:29:54 -0500 )edit

Please find the logs above.

soumitrakarmakar gravatar imagesoumitrakarmakar ( 2016-02-18 23:24:16 -0500 )edit

Did you solve this problem? tell me about. I got same issue.

whoansoo gravatar imagewhoansoo ( 2019-01-23 16:10:18 -0500 )edit