flat instances don't get IP address

asked 2016-02-15 08:21:38 -0600

malascom gravatar image

I was following the Liberty installation guide and at the end when i lunch a Public provider network and when i lunch the instance and try to access the instance using the virtual console the instance has no IP address. i can not do the tests.

my neutron.conf is:

[DEFAULT]

core_plugin = ml2

service_plugins = router

auth_strategy = keystone


allow_overlapping_ips = True




notify_nova_on_port_status_changes = True


notify_nova_on_port_data_changes = True


nova_url = http://controller:8774/v2


rpc_backend = rabbit


[keystone_authtoken]

auth_uri = http://controller:5000
auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = neutron
password = xxx


[database]

connection = mysql+pymysql://neutron:alascom@controller/neutron


[nova]


auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
region_name = RegionOne
project_name = service
username = nova
password = xxx

# PEM encoded Certificate Authority to use when verifying HTTPs connections.
# cafile =

# PEM encoded client certificate cert file
# certfile =

# Verify HTTPS connections.
# insecure = False

# PEM encoded client certificate key file
# keyfile =

# Name of nova region to use. Useful if keystone manages more than one region.
# region_name =

# Timeout value for http requests
# timeout =

[oslo_concurrency]

lock_path = $state_path/lock


[oslo_messaging_rabbit]




rabbit_host = controller
rabbit_userid = openstack
rabbit_password = xxx

my /etc/neutron/plugins/ml2/ml2_conf.ini is :

[ml2]


type_drivers = local, flat

tenant_network_types = vxlan

mechanism_drivers = linuxbridge,l2population

extension_drivers = port_security

[ml2_type_flat]


flat_networks = public



[ml2_type_vxlan]


vni_ranges = 1:1000



[securitygroup]

enable_ipset = True

my /etc/neutron/plugins/ml2/linuxbridge_agent.ini is :

[linux_bridge]

physical_interface_mappings = public:eth0

[vxlan]


enable_vxlan = True
local_ip = 10.71.71.8
l2_population = True

[agent]


prevent_arp_spoofing = True

[securitygroup]

firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

enable_security_group = True

my /etc/neutron/l3_agent.ini is :

[DEFAULT]

interface_driver = neutron.agent.linux.interface.BridgeInterfaceDriver


external_network_bridge =

and the /etc/neutron/dhcp_agent.ini is:

[DEFAULT]

interface_driver = neutron.agent.linux.interface.BridgeInterfaceDriver

dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq


enable_isolated_metadata = True


dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf

my ifconfig is:

eth0      Link encap:Ethernet  HWaddr 00:0c:29:d1:14:92
          inet addr:10.70.70.8  Bcast:10.70.70.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fed1:1492/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:424552 errors:0 dropped:64 overruns:0 frame:0
          TX packets:35419 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:364178739 (364.1 MB)  TX bytes:80672066 (80.6 MB)

eth1      Link encap:Ethernet  HWaddr 00:0c:29:d1:14:9c
          inet addr:10.71.71.8  Bcast:10.71.71.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fed1:149c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:49275 errors:0 dropped:52 overruns:0 frame:0
          TX packets:41207 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16649043 (16.6 MB)  TX bytes:13268744 (13.2 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:274023 errors:0 dropped:0 overruns:0 frame:0
          TX packets:274023 errors:0 dropped:0 ...
(more)
edit retag flag offensive close merge delete