Ask Your Question
0

Couldn't obtain IP address of instance

asked 2016-02-11 07:23:42 -0500

socfreak390 gravatar image

ceilometer-acentral.log keeps giving me this error.

ERROR ceilometer.hardware.discovery [req-48f8d9fd-2a35-4b24-9b71-f6be9cc691bd admin - - - -] Couldn't obtain IP address of instance fa90fd3b-47f1-4d78-99be-f63d2c3ac1be

Any idea how to resolve this? I am running Openstack from devstack

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-18 03:00:03 -0500

yprokule gravatar image

The idea of hardware* pollsters is to get data via snmp, and 'discovery' module expects vms to be on the 'ctlplane' network. This will work when U have an undercloud and overcloud installed. To get rid of this message, if U're using default pipeline.yaml - disable hardware* pollsters. If U need them - manually configure pipeline.yaml with credentials/hosts|ips

edit flag offensive delete link more

Comments

So how would I disable hardware pollsters? I'm seeing no reference to them in my pipeline.yaml

j-harbott gravatar imagej-harbott ( 2016-07-06 07:55:39 -0500 )edit

@j-rosenboom, most likely U have a wildcard entry *. if so, update that section to look like:

- source: meters
  meters:
    - '!hardware.*'
  sinks

And restart ceilometer* services

yprokule gravatar imageyprokule ( 2016-07-06 08:58:16 -0500 )edit

Thanks, that seems to do the trick, great!

j-harbott gravatar imagej-harbott ( 2016-07-06 09:40:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-11 07:23:42 -0500

Seen: 1,064 times

Last updated: Feb 18 '16