Ask Your Question
2

Magnum bay create fails with the error (a user and password or token is required. (HTTP 500))

asked 2016-02-11 00:07:25 -0500

Jagan Prakash gravatar image

updated 2016-03-19 14:01:57 -0500

I have put magnum setup in openstack liberty. I was able to create the baymodal in magnum setup but I can't able to create a bay using magnum baymodal getting the below error.

ERROR: reason: A user and password or token is required. (HTTP 500)

Configuration file of magnum

[DEFAULT]

enable_authentication = true

debug = true

log_file = magnum

log_dir = /var/log/magnum

rpc_backend = rabbit

[api]
port = 9511

host = 192.168.1.220

[barbican_client]

[bay]

[bay_heat]

[certificates]

[conductor]

[database]

connection = mysql+pymysql://magnum:openstack@libertycontroller/magnum

[docker]

[glance_client]

[heat_client]

[keystone_authtoken]

auth_uri = http://libertycontroller:5000

auth_url = http://libertycontroller:35357

auth_plugin = password

project_domain_id = default

user_domain_id = default

project_name = service

username = magnum

password = openstack

region_name = RegionOne

[magnum_client]

[matchmaker_redis]

[matchmaker_ring]

[nova_client]

[oslo_concurrency]

[oslo_messaging_amqp]

[oslo_messaging_qpid]

[oslo_messaging_rabbit]

rabbit_host = libertycontroller

rabbit_userid = openstack

rabbit_password = openstack

[oslo_policy]

[x509]

attaching the log of the magnum api

2016-02-11 09:51:40.104 25241 DEBUG keystoneauth.identity.v3.base [req-1464abec-fd20-4fc5-a89f-75bc9fe4b66c admin admin - - -] Making authentication request to http://libertycontroller:35357/v3/auth/tokens get_auth_ref /usr/local/lib/python2.7/dist-packages/keystoneauth1/identity/v3/base.py:164

2016-02-11 09:51:40.193 25241 DEBUG keystoneauth.session [req-1464abec-fd20-4fc5-a89f-75bc9fe4b66c admin admin - - -] REQ: curl -g -i -X GET http://libertycontroller:35357/v3/auth/tokens -H "X-Subject-Token: {SHA1}ed6ea35266c6f0545f58020071662ff63f9b7393" -H "User-Agent: python-keystoneclient" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}d189f137c5ed2d45b8e70c6012c679664ee82806" _http_log_request /usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py:225

2016-02-11 09:51:40.232 25241 DEBUG keystoneauth.session [req-1464abec-fd20-4fc5-a89f-75bc9fe4b66c admin admin - - -] RESP: [200] Content-Length: 6453 X-Subject-Token: {SHA1}ed6ea35266c6f0545f58020071662ff63f9b7393 Vary: X-Auth-Token Keep-Alive: timeout=5, max=99 Server: Apache/2.4.7 (Ubuntu) Connection: Keep-Alive Date: Thu, 11 Feb 2016 04:21:40 GMT x-openstack-request-id: req-d7d17049-3c51-4b73-8ae9-3abfb6e8cda8 Content-Type: application/json X-Distribution: Ubuntu 

RESP BODY: {"token": {"methods": ["password"], "roles": [{"id": "b76fc7e3dc454d89b00fabcfbfefe899", "name": "admin"}], "expires_at": "2016-02-11T05:21:40.095790Z", "project": {"domain": {"id": "default", "name": "Default"}, "id": "64cc062bd5374c2394649d830c71321e", "name": "admin"}, "catalog": "<removed>", "extras": {}, "user": {"domain": {"id": "default", "name": "Default"}, "id": "8711aaa4017a45ecade46565d8616a13", "name": "admin"}, "audit_ids": ["3XRKCUC8RjGxcyie1Nv4qw"], "issued_at": "2016-02-11T04:21:40.095817Z"}}
 _http_log_response /usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py:254

2016-02-11 09:51:40.237 25241 DEBUG oslo_messaging._drivers.amqpdriver [req-886239f9-94cc-47db-87d1-72819c21b0ca admin admin - - -] CALL msg_id: 9b0773246617467db53897f6b56ffc72 exchange 'magnum' topic 'magnum-conductor' _send /usr/local/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:450

2016-02-11 09:51:40.250 25241 DEBUG oslo_messaging._drivers.amqpdriver [req-886239f9-94cc-47db-87d1-72819c21b0ca admin admin - - -] received reply msg_id: 9b0773246617467db53897f6b56ffc72 __call__ /usr/local/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:298
192.168.1.220 - - [11/Feb/2016 09:51:40] "GET /v1/baymodels/k8sbaymodel HTTP/1.1" 200 859

2016-02-11 09:51:40.261 25241 DEBUG oslo_messaging._drivers.amqpdriver [req-0aa078a9-2553-4dbc-b77a-58410747d790 admin admin - - -] CALL msg_id: b5ce5d2fae8c4276b24d30e745e79b88 exchange 'magnum' topic 'magnum-conductor' _send /usr/local/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:450

2016-02-11 09:51:40.272 25241 DEBUG oslo_messaging._drivers.amqpdriver [req-0aa078a9-2553-4dbc-b77a-58410747d790 admin admin - - -] received reply msg_id: b5ce5d2fae8c4276b24d30e745e79b88 __call__ /usr/local/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:298

2016-02-11 09:51:40.295 25241 DEBUG oslo_messaging._drivers.amqpdriver [req-0aa078a9-2553-4dbc-b77a-58410747d790 admin admin - - -] CALL msg_id: 0297f6b2dc8840579f63e0e3f9593bcc exchange 'magnum' topic 'magnum-conductor' _send /usr/local/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py:450

2016-02-11 ...
(more)
edit retag flag offensive close merge delete

Comments

Im having the same issue, have you resolved?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-04-08 11:47:12 -0500 )edit
1

The simplest solution is to turn off Barbican (You don't have to use Barbican in dev environment):

[certificates] cert_manager_type = local

If you want to use Barbican, try to add the admin credentials:

[keystone_authtoken] .. admin_tenant_name = .. admin_password = .. admin_user = ..

hongbin034 gravatar imagehongbin034 ( 2016-04-09 20:50:41 -0500 )edit

Please feel free to let me know if above steps didn't work.

hongbin034 gravatar imagehongbin034 ( 2016-04-09 20:56:19 -0500 )edit

Not, already had certificates at local and still dont working

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-04-10 04:22:52 -0500 )edit

Sorry to hear that. I want to confirm a few things: * Which version of Magnum you are using (i.e. liberty, mitaka or master) * Are you using devstack? If yes, which version you are using? * It would be helpful if you can post the logs and the config file as the author of this question.

hongbin034 gravatar imagehongbin034 ( 2016-04-10 09:02:52 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-22 12:50:58 -0500

Davide gravatar image

Hi,

i think in magnum.conf the [trust] section is missing:

[trust]
trustee_domain_admin_password = %MAGNUM_DOMAIN_ADMIN_PASS%
trustee_domain_admin_id = %MAGNUM_DOMAIN_ADMIN_ID%
trustee_domain_id = %MAGNUM_DOMAIN_ID%

Of course the resources should also exists in Keystone. This follow the same logic as the heat stack domain. You need a magnum domain and a user which has the admin role for that domain.

edit flag offensive delete link more

Comments

After adding the above trust details I am getting below error

TrusteeCreateFailed_Remote: Failed to create trustee 4ce667ca-6b03-44d2-866e-b872fde9b79c in domain 61a6f2b431c8475dbcc40e756cf3d8d6 Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatch

NarasimhaSV gravatar imageNarasimhaSV ( 2016-04-26 03:16:08 -0500 )edit

It is mentioning like unable create trustee for the bay creation request

NarasimhaSV gravatar imageNarasimhaSV ( 2016-04-26 03:16:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-02-11 00:07:25 -0500

Seen: 1,154 times

Last updated: Mar 19 '16