Ask Your Question
0

heat stack create error:ERROR heat.engine.resource [-] CREATE : WaitCondition "WaitCondition"

asked 2013-12-16 05:26:16 -0500

vladber gravatar image

updated 2013-12-16 12:02:08 -0500

smaffulli gravatar image

Working with Havana. While launching the AutoScalingMultiAZSample.template for F18 template I get this error:

ERROR heat.engine.resource [-] CREATE : WaitCondition "WaitCondition"

More details from heat-engine.log :

2013-12-16 10:39:30.171 17352 ERROR heat.engine.resource [-] CREATE : WaitCondition "WaitCondition"
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource Traceback (most recent call last):
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource   File "/usr/lib/python2.7/dist-packages/heat/engine/resource.py", line 358, in _do_action
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource     handle_data = handle()
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource   File "/usr/lib/python2.7/dist-packages/heat/engine/resources/wait_condition.py", line 190, in handle_create
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource     self._validate_handle_url()
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource   File "/usr/lib/python2.7/dist-packages/heat/engine/resources/wait_condition.py", line 146, in _validate_handle_url
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource     handle_id = identifier.ResourceIdentifier.from_arn_url(handle_url)
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource   File "/usr/lib/python2.7/dist-packages/heat/common/identifier.py", line 79, in from_arn_url
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource     raise ValueError('"%s" is not a valid URL' % url)
2013-12-16 10:39:30.171 17352 TRACE heat.engine.resource ValueError: "/arn%3Aopenstack%3Aheat%3A%3Aaf54773bea5c49c395f9d45172d83e4a%3Astacks%2FWP24-ElasticLoadBalancer-gu4mftkczphv%2Fe9aefea5-9c00-487d-a088-14436b744868%2Fresources%2FWaitHandle?Timestamp=2013-12-16T08%3A39%3A21Z&SignatureMethod=HmacSHA256&AWSAccessKeyId=5347301bb28a47729f5f6f439435490e&SignatureVersion=2&Signature=BuWP7NMj3a%2Fy1sYIGQE%2Bd8uEZAVy2ZiBmTunBpZR1%2Bg%3D" is not a valid URL

Earlier I suceeded to launch WordPress_Single_Instance.template.

edit retag flag offensive close delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-01-06 00:35:59 -0500

DennyZhang gravatar image

updated 2014-01-06 00:36:12 -0500

Checking the code, it's expected the url to start with http or https. https://github.com/openstack/heat/blob/stable/havana/heat/common/identifier.py#L77-79

It's probably a misconfiguration in heat.conf, say heat_waitcondition_server_url option.

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2013-12-16 05:26:16 -0500

Seen: 153 times

Last updated: Jan 06