Ask Your Question
0

Unable to start httpd service on controller node with kilo on Centos7

asked 2016-02-03 16:43:44 -0500

Rajan433 gravatar image

[root@controller ~]# systemctl status httpd.service ● httpd.service - The Apache HTTP Server Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled) Drop-In: /usr/lib/systemd/system/httpd.service.d └─openstack-dashboard.conf Active: failed (Result: exit-code) since Wed 2016-02-03 17:25:10 EST; 12min ago Docs: man:httpd(8) man:apachectl(8) Process: 2799 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE) Process: 2796 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE) Process: 2760 ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py compress --force (code=exited, status=0/SUCCESS) Process: 981 ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear (code=exited, status=0/SUCCESS) Main PID: 2796 (code=exited, status=1/FAILURE)

Feb 03 17:25:10 controller httpd[2796]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000 Feb 03 17:25:10 controller httpd[2796]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000 Feb 03 17:25:10 controller httpd[2796]: no listening sockets available, shutting down Feb 03 17:25:10 controller httpd[2796]: AH00015: Unable to open logs Feb 03 17:25:10 controller systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE Feb 03 17:25:10 controller kill[2799]: kill: cannot find process "" Feb 03 17:25:10 controller systemd[1]: httpd.service: control process exited, code=exited status=1 Feb 03 17:25:10 controller systemd[1]: Failed to start The Apache HTTP Server. Feb 03 17:25:10 controller systemd[1]: Unit httpd.service entered failed state. Feb 03 17:25:10 controller systemd[1]: httpd.service failed.

journalctl -xe reports following

[root@controller ~]# journalctl -xe Feb 03 17:42:49 controller nova-conductor[949]: listener.cb(fileno) Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 217, in main Feb 03 17:42:49 controller nova-conductor[949]: self._resolve_links() Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 232, in _resolve_links Feb 03 17:42:49 controller nova-conductor[949]: f(self, ca, *ckw) Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/oslo_messaging/_executors/impl_eventlet.py", line 44, in complete Feb 03 17:42:49 controller nova-conductor[949]: thread.wait() Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 175, in wait Feb 03 17:42:49 controller nova-conductor[949]: return self._exit_event.wait() Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/eventlet/event.py", line 125, in wait Feb 03 17:42:49 controller nova-conductor[949]: current.throw(self._exc) Feb 03 17:42:49 controller nova-conductor[949]: File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 214, in main Feb 03 17:42:49 controller nova-conductor[949]: result = function(args, **kwargs) Feb 03 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-02-12 04:02:52 -0500

Keystone and httpd were listening to same port and hostname, so kindly try this approach. ( centos7 )

check for the services : systemctl status openstack-keystone httpd.service;

If any one is up stop the services in order: systemctl stop httpd.service; systemctl stop openstack-keystone**

Edit the following in /etc/keystone/keystone.conf connection = mysql://keystone:KEYSTONE_PWD@localhost/keystone admin_bind_host = <controller ip=""> public_bind_host = <controller ip="">

Edit the following in /etc/httpd/conf.d/wsgi-keystone.conf modify the Listen & Virualhost line to below Listen 127.0.0.1:5000 Listen 127.0.0.1:35357

<virtualhost 127.0.0.1:5000=""> <virtualhost 127.0.0.1:35357="">

Start the service in order systemctl startopenstack-keystone; systemctl start httpd;

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-02-03 16:43:44 -0500

Seen: 3,713 times

Last updated: Feb 03 '16