Openstack not showing hypervisor and availability zones [closed]

asked 2013-12-16 00:52:35 -0500

anshul tripathi gravatar image

updated 2013-12-16 12:01:17 -0500

smaffulli gravatar image

Hi I have done a 2 node installation of Openstack Havana . One is the controller node and other one is the compute node. I am using nova-compute-qemu for hypervisor. Also I havent installed neutron. I am using nova-network . Both the nodes show that all the services are running fine

Nova-manage service list on controller
nova-cert        controller                           internal         enabled    :-)   2013-12-16 06:46:14
nova-conductor   controller                           internal         enabled    :-)   2013-12-16 06:46:08
nova-consoleauth controller                           internal         enabled    :-)   2013-12-16 06:46:11
nova-scheduler   controller                           internal         enabled    :-)   2013-12-16 06:46:14
nova-network     controller                           internal         enabled  :-)

Nova-manage service list on compute
Binary           Host                                 Zone             Status     State Updated_At
nova-compute     compute1                             nova             enabled    :-)   2013-12-16 06:47:22.538664
nova-network     compute1                             nova             enabled    :-)   2013-12-16 06:47:26.629114

But it does not show the hypervisor in Horizon and while launching an install it shows no availability zone. What might be the problem. Is the connection proper?

Do i require bridges for the connection between the compute node and the controller node? Current I just have two ethernet adapters on each node one internal and one external and no bridges.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2017-05-24 13:56:13.049059

Comments

Can you post the `sql_connection` setting from `/etc/nova/nova.conf` on both your controller and compute node? Make sure to anonymize any password before posting.

larsks gravatar imagelarsks ( 2013-12-16 12:39:41 -0500 )edit

Compute Node Mysql setting --connection = mysql://nova:nova_password@controller/nova Controller Node Mysql Setting [database] connection = mysql://nova:nova_pass@controller/nova

anshul tripathi gravatar imageanshul tripathi ( 2013-12-17 00:10:38 -0500 )edit

As given in the manual I have deleted the file /var/lib/nova/nova.sqlite but it comes back again.

anshul tripathi gravatar imageanshul tripathi ( 2013-12-17 01:30:37 -0500 )edit

Have you restarted all your nova services on the compute node (probably just the nova-compute service)? It really sounds like your compute node has the wrong database setting, but the configuration you posted in your earlier comment seems correct.

larsks gravatar imagelarsks ( 2013-12-17 08:24:37 -0500 )edit
1

yes i have restarted all the services. I am also confused what the problem might be.

anshul tripathi gravatar imageanshul tripathi ( 2013-12-18 07:41:44 -0500 )edit