Ask Your Question
0

unable to ping router

asked 2016-01-28 09:51:13 -0500

angelinux gravatar image

Hello, I followed the install guide for liberty launching instances on private networks (option 2) but I am unable to ping the virtual router

    neutron router-port-list router
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 6384c950-ab12-4514-b582-78a80fcd267a |      | fa:16:3e:4b:d4:00 | {"subnet_id": "57db368e-9dad-42be-a3eb-58399266acf4", "ip_address": "192.107.88.61"} |
| b66d679f-3d6b-4784-a802-94eb827d3167 |      | fa:16:3e:49:79:85 | {"subnet_id": "da685b38-b88b-4a35-9ebb-37c37ea322c3", "ip_address": "192.168.10.1"}  |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+

my public network is 192.107.88.0/25 and the private one is 192.168.10.0/24

    ping 192.107.88.61
PING 192.107.88.61 (192.107.88.61) 56(84) bytes of data.
^C
--- 192.107.88.61 ping statistics ---
14 packets transmitted, 0 received, 100% packet loss, time 13104ms

while ping versus other hosts works well. Please let ne know. Angelinux

edit retag flag offensive close merge delete

Comments

Network setup should appear like - https://github.com/mohi048/openstack-...

Mohit gravatar imageMohit ( 2016-03-03 00:28:09 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-02 13:42:38 -0500

Radhakrishnan Rk gravatar image

Hi

Check the admin state of the router as well as status of the router.

admin state should be true

router status should be active

If not, run the command neutron router-update router-id --admin-state-up

Best Regards,

Radhakrishnan R

edit flag offensive delete link more

Comments

I have the same problem and the admin_state_up is True and status is ACTIVE but still can't ping router, nor public neither private interfaces.

jonathan gravatar imagejonathan ( 2016-03-29 03:57:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-01-28 09:37:28 -0500

Seen: 82 times

Last updated: Mar 02 '16