Ask Your Question
1

liberty on ubuntu install guide unable to ping router

asked 2016-01-28 09:36:31 -0500

angelinux gravatar image

Hello, I followed the install guide in http://docs.openstack.org/liberty/install-guide-ubuntu/launch-instance-networks-private.html (link text) but I am unable to ping the virtual router

    neutron router-port-list router
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 6384c950-ab12-4514-b582-78a80fcd267a |      | fa:16:3e:4b:d4:00 | {"subnet_id": "57db368e-9dad-42be-a3eb-58399266acf4", "ip_address": "192.107.88.61"} |
| b66d679f-3d6b-4784-a802-94eb827d3167 |      | fa:16:3e:49:79:85 | {"subnet_id": "da685b38-b88b-4a35-9ebb-37c37ea322c3", "ip_address": "192.168.10.1"}  |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+

my public network is 192.107.88.0/25 and the private one is 192.168.10.0/24

    ping 192.107.88.61
PING 192.107.88.61 (192.107.88.61) 56(84) bytes of data.
^C
--- 192.107.88.61 ping statistics ---
14 packets transmitted, 0 received, 100% packet loss, time 13104ms

while ping versus other hosts works well. Please let ne know. Angelinux

edit retag flag offensive close merge delete

Comments

I have the very exact problem, did you finally solve it?

jonathan gravatar imagejonathan ( 2016-03-28 11:57:11 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-06 04:55:54 -0500

jonathan gravatar image

I had the same issue and i solved it just by reinstalling neutron (uninstalling all packages related to neutron and installing and editing the config files again). I also have to reinstall nova and horizon in the controller node as they were uninstalled too.

To debug it this problem first i get the neutron agent list:

# neutron agent-list

and shows that one of the linux bridge agents is not running (in my case the one in the controller node), the field 'Alive' is XXX. Also, the port in the router that acts as the interface of the public network shows that the binding:vif_type is binding_fail:

# neutron port-show <id-puerto-router-gateway>
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| Field                 | Value                                                                                                                 |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                                                  |
| allowed_address_pairs |                                                                                                                       |
| binding:host_id       | puccini                                                                                                               |
| binding:profile       | {}                                                                                                                    |
| binding:vif_details   | {"port_filter": true}                                                                                                 |
| binding:vif_type      | binding_fail                                                                                                               |
| binding:vnic_type     | normal                                                                                                                |
| device_id             | ccb7fd27-a791-4033-96ab-6aee33edcbda                                                                                  |
| device_owner          | network:router_gateway                                                                                                |
| dns_assignment        | {"hostname": "host-163-117-141-129", "ip_address": "163.117.141.129", "fqdn": "host-163-117-141-129.openstacklocal."} |
| dns_name              |                                                                                                                       |
| extra_dhcp_opts       |                                                                                                                       |
| fixed_ips             | {"subnet_id": "7f6d387c-4edb-4e52-a594-0cbd67712c3a", "ip_address": "163.117.141.129"}                                |
| id                    | c13cad36-05d9-405e-a677-d95c3ea01d6b                                                                                  |
| mac_address           | fa:16:3e:f4:36:39                                                                                                     |
| name                  |                                                                                                                       |
| network_id            | 3a39126e-748b-45b5-8169-6eee192fae29                                                                                  |
| port_security_enabled | False                                                                                                                 |
| security_groups       |                                                                                                                       |
| status                | DOWN                                                                                                                |
| tenant_id             |                                                                                                                       |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+

It is also worth mentioning that the official guide of liberty installation lacks some configuration parameters (as described https://bugs.launchpad.net/nova/+bug/1519641/comments/18 (here) and https://bugs.launchpad.net/nova/+bug/1519641/comments/22 (here), which causes the following failure when trying to boot instances:

ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.<class 'keystoneclient.exceptions.BadRequest'> (HTTP 500) (Request-ID: req-7acc4f88-51fc-4c0b-9748-361a2e9a6ad9)

Jonathan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-28 09:36:31 -0500

Seen: 119 times

Last updated: Apr 06 '16