Ask Your Question
1

trouble with liberty on ubuntu with Linux bridge agent and provider networks

asked 2016-01-27 03:59:05 -0500

SergeC gravatar image

updated 2016-01-28 02:37:32 -0500

Hello I have trouble installing liberty on ubuntu following the openstack guide,using Networking Option 1: Provider networks

On the controller:
Linux bridge agent is failing with 'LinuxBridgeNeutronAgentRPC' object has no attribute 'state_rpc'

/etc/neutron/plugins/ml2/ml2_conf.ini

[ml2]
type_drivers = flat,vlan
tenant_network_types =
mechanism_drivers = linuxbridge
extension_drivers = port_security

[ml2_type_flat]
flat_networks = public

[ml2_type_vlan]

[ml2_type_gre]

[ml2_type_vxlan]

[ml2_type_geneve]

[securitygroup]
enable_ipset = True

/etc/neutron/plugins/ml2/linuxbridge_agent.ini

[linux_bridge]
physical_interface_mappings = public:em2

[vxlan]
enable_vxlan = False

[agent]
prevent_arp_spoofing = True

[securitygroup]
enable_security_group = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

cat neutron-plugin-linuxbridge-agent.log

2016-01-27 10:07:14.501 28707 CRITICAL neutron [-] AttributeError: 'LinuxBridgeNeutronAgentRPC' object has no attribute 'state_rpc'
2016-01-27 10:07:14.501 28707 ERROR neutron Traceback (most recent call last):
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/bin/neutron-linuxbridge-agent", line 10, in <module>
2016-01-27 10:07:14.501 28707 ERROR neutron     sys.exit(main())
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/linuxbridge/agent/linuxbridge_neutron_agent.py", line 1158, in main
2016-01-27 10:07:14.501 28707 ERROR neutron     launcher.wait()
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_service/service.py", line 281, in wait
2016-01-27 10:07:14.501 28707 ERROR neutron     status, signo = self._wait_for_exit_or_signal(ready_callback)
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_service/service.py", line 268, in _wait_for_exit_or_signal
2016-01-27 10:07:14.501 28707 ERROR neutron     self.stop()
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_service/service.py", line 196, in stop
2016-01-27 10:07:14.501 28707 ERROR neutron     self.services.stop()
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_service/service.py", line 612, in stop
2016-01-27 10:07:14.501 28707 ERROR neutron     service.stop()
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/linuxbridge/agent/linuxbridge_neutron_agent.py", line 882, in stop
2016-01-27 10:07:14.501 28707 ERROR neutron     self.set_rpc_timeout(self.quitting_rpc_timeout)
2016-01-27 10:07:14.501 28707 ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/linuxbridge/agent/linuxbridge_neutron_agent.py", line 1124, in set_rpc_timeout
2016-01-27 10:07:14.501 28707 ERROR neutron     self.state_rpc):
2016-01-27 10:07:14.501 28707 ERROR neutron AttributeError: 'LinuxBridgeNeutronAgentRPC' object has no attribute 'state_rpc'
2016-01-27 10:07:14.501 28707 ERROR neutron
2016-01-27 10:07:15.142 29877 INFO neutron.common.config [-] Logging enabled!
2016-01-27 10:07:15.143 29877 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 7.0.0
2016-01-27 10:07:15.143 29877 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {'public': 'em2'}
2016-01-27 10:07:15.144 29877 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2016-01-27 10:07:15.144 29877 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Agent initialized successfully, now running...
2016-01-27 10:07:15.182 29877 ERROR neutron.agent.linux.utils [req-1ed1f07e-e6dd-4162-ab92-744b5ecc54f3 - - - - -]

root@:/etc/network# cat ...

(more)
edit retag flag offensive close merge delete

Comments

Did you get the solution for this, I am also facing the same issue.

Vinodp gravatar imageVinodp ( 2016-03-17 00:33:18 -0500 )edit

same problem here.....@@

Jiangjunyu gravatar imageJiangjunyu ( 2016-03-18 05:29:22 -0500 )edit

please post the whole agent log to http://paste.openstack.org/

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-05-17 12:36:21 -0500 )edit

put detail log. add 'debug=true'

Carrot gravatar imageCarrot ( 2016-05-17 19:54:27 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-05-17 11:23:00 -0500

Hi, I also encountered the same issue similar to the logs you've shared. I'm using Networking Option 2: Self-service networks. You probably need to check the interfaces. I've noticed you're using em2 as your interface device mapping. Check if it show if you execute ifconfig, if it doesn't try to bring it up. If ifup still doesn't work, try to reboot your machine.

HTH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-27 03:59:05 -0500

Seen: 1,967 times

Last updated: May 17 '16