devstack ovn no public network

asked 2016-01-25 14:03:22 -0500

bschang gravatar image

I'm following the instructions here: http://docs.openstack.org/developer/networking-ovn/testing.html (http://docs.openstack.org/developer/n...)

I've run this setup previously without issues, but when I pulled the repositories today and ran stack.sh, there was no public network or router configured.

This is the output of neutron net-list:

+--------------------------------------+---------+----------------------------------------------------------+
| id                                   | name    | subnets                                                  |
+--------------------------------------+---------+----------------------------------------------------------+
| 462a3d28-6e51-42d7-a2bf-872b8b4fba50 | private | 932ef86f-eb4f-4e45-b5d9-2588caf60783 fd5d:43f5:d5ca::/64 |
|                                      |         | cd1b8fd2-a12e-4446-966b-fa2fbf34e730 10.0.0.0/24         |
+--------------------------------------+---------+----------------------------------------------------------+

neutron router-list returns no output.

This is my local.conf (which is the same local.conf.sample in the networking-ovn repository):

#
# Sample DevStack local.conf.
#
# This sample file is intended to be used for your typical DevStack environment
# that's running all of OpenStack on a single host.  This can also be used as
# the first host of a multi-host test environment.
#
# No changes to this sample configuration are required for this to work.
#

[[local|localrc]]

LOGFILE=/home/ubuntu/stack.sh.log

DATABASE_PASSWORD=password
RABBIT_PASSWORD=password
SERVICE_PASSWORD=password
SERVICE_TOKEN=password
ADMIN_PASSWORD=password

# The DevStack plugin defaults to using the ovn branch from the official ovs
# repo.  You can optionally use a different one.  For example, you may want to
# use the latest patches in blp's ovn branch:
#OVN_REPO=http://github.com/blp/ovs-reviews.git
#OVN_BRANCH=origin/ovn

enable_plugin networking-ovn http://git.openstack.org/openstack/networking-ovn
enable_service ovn-northd
enable_service ovn-controller

# Use Neutron instead of nova-network
disable_service n-net
enable_service q-svc
# OVN uses the DHCP and L3 agents for now.  They will be dropped once the
# corresponding functionality is available in OVN.
enable_service q-dhcp
enable_service q-meta

# We have to disable the neutron L2 agent. OVN does not use the L2 agent.
disable_service q-agt

# How to connect to ovsdb-server hosting the OVN databases.
#OVN_REMOTE=tcp:$SERVICE_HOST:6640

# A UUID to uniquely identify this system.  If one is not specified, a random
# one will be generated and saved in the file 'ovn-uuid' for re-use in future
# DevStack runs.
#OVN_UUID=

# Whether to enable using OVN's L3 functionality. If this value is disabled,
# Openstack will use the q-l3 functionality.  If you set OVN_L3_MODE to True,
# you must also disable the q-l3 service.
OVN_L3_MODE=True
#enable_service q-l3
disable_service q-l3

# Whether or not to build custom openvswitch kernel modules from the ovs git
# tree. This is enabled by default.  This is required unless your distro kernel
# includes ovs+conntrack support.  This support was first released in Linux 4.3,
# and will likely be backported by some distros.
#OVN_BUILD_MODULES=True

The logs don't seem to indicate any issue with configuring the public network/subnet or router. Can anyone help me debug this issue?

edit retag flag offensive close merge delete