Ask Your Question
2

Keystone token generation fails for DevStack

asked 2016-01-24 09:59:28 -0500

gbraad gravatar image

updated 2016-01-27 01:47:11 -0500

During the installation of DevStack, I am unable to get keystone tokens generated.

++ openstack token issue -c id -f value --os-username admin --os-project-name admin --os-user-domain-id default --os-project-domain-id default --os-identity-api-version 3 --os-auth-url http://127.0.0.1:35357 --os-password secrete Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Could not determine a suitable URL for the plugin

For a more detailed output, look at https://gist.github.com/gbraad/2b21efe725e511da446a

It seems this occurs on _Ubuntu_, _CentOS_ and _Fedora_. What could be the cause of this?

The local.confI am using is

[[local|localrc]]
DEST=/opt/stack
HOST_IP=127.0.0.1
ADMIN_PASSWORD=secrete
MYSQL_PASSWORD=secrete
RABBIT_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
enable_plugin neutron-lbaas https://github.com/openstack/neutron-lbaas.git
enable_plugin octavia https://github.com/openstack/octavia.git
ENABLED_SERVICES=key,horizon,mysql,rabbit,sysstat,cinder,c-api,c-vol,c-sch,g-ap,g-reg,n-api,n-crt,n-obj,n-cpu,n-sch,n-cauth,n-novnc,n-xvnc,n-cond,neutron,q-svc,q-agt,q-dhcp,q-l3,q-meta
ENABLED_SERVICES+=,q-lbaasv2
ENABLED_SERVICES+=,octavia,o-cw,o-hk,o-hm,o-api

https://launchpadlibrarian.net/234869432/local.conf

edit retag flag offensive close merge delete

Comments

I'm having the same issue. Have you managed to solve this yet?

jafar gravatar imagejafar ( 2016-02-24 14:43:24 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2017-09-27 18:49:57 -0500

kbhonagiri gravatar image

check if apache2 is running. Generally happens if any server is running on port 80

edit flag offensive delete link more
0

answered 2016-04-25 03:44:23 -0500

You saved my day. This worked. Thank you

edit flag offensive delete link more
2

answered 2016-03-04 04:50:54 -0500

Gourav Singla gravatar image

If you are behind the proxy, then you have to set no_proxy environmental variable for your localhost and all the IPs acquire by you host. Like if ip is 192.168.10.10, then:

 ./unstack.sh
export  no_proxy=127.0.0.1,192.168.10.10
./stack.sh

Hope this will help!!

edit flag offensive delete link more

Comments

It worked for me, and more suggestion, we can change the command as: export no_proxy='localhost,127.0.0.1,192.168.10.10' because sometimes "localhost" is used in place of"127.0.0.1"

deepak_Stack gravatar imagedeepak_Stack ( 2016-08-02 04:54:15 -0500 )edit
1

answered 2016-03-03 05:12:01 -0500

ajaym gravatar image

This solved the problem for me: ./unstack.sh export no_proxy=<your host="" ip="">/8,localhost,127.0.0.0/8,.localdomain ./stack.sh

edit flag offensive delete link more

Comments

haven't been able to reproduce this, but previously it had not failed (no proxy is used). but thanks. When I run into this again I will try

gbraad gravatar imagegbraad ( 2016-05-12 21:13:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-01-24 09:59:28 -0500

Seen: 7,418 times

Last updated: Sep 27 '17