Unable to install keystone: bad gateway (502)

asked 2016-01-20 11:10:05 -0500

adil gravatar image

updated 2016-02-16 09:40:54 -0500

Hello,

I am using "sudo packstack --allinone" to install an all-in-one openstack instance and i am getting this error:

Stack Trace:

Applying 172.16.158.73_keystone.pp
Applying 172.16.158.73_glance.pp
Applying 172.16.158.73_cinder.pp
172.16.158.73_keystone.pp:                        [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 172.16.158.73_keystone.pp
Error: Could not prefetch keystone_service provider 'openstack': Execution of '/usr/bin/openstack service list --quiet --format csv --long' returned 1: Bad Gateway (HTTP 502)
You will find full trace in log /var/tmp/packstack/20160120-174929-ppQ1nK/manifests/172.16.158.73_keystone.pp.log
Please check log file /var/tmp/packstack/20160120-174929-ppQ1nK/openstack-setup.log for more information
Additional information:
 * A new answerfile was created in: /root/packstack-answers-20160120-174930.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
edit retag flag offensive close merge delete

Comments

That error usually comes from an installation behind a proxy. Try exporting environment variable:

no_proxy=localhost,127.0.0.1,<IP_HOST>

Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-02-16 09:42:05 -0500 )edit