Ask Your Question
0

connectivity chain diagnose

asked 2016-01-20 10:26:25 -0600

Wohard gravatar image

updated 2016-02-05 07:14:36 -0600

Hello everyone. THE UPDATE IS DOWN : the situation can be understood alone

I need some help to diagnose my OpenStack connectivity.
here is my network architecture with addresses. Openstack is installed inside 192.168.2.48 host.
From the local network 192.168.3.46 : I can ping all the elements of network (GW, DNS, 192.168.2.48)
From 192.168.2.48 : I can ping DNS, GW, Host A, router 192.168..3.205.
From router : I can ping instance and 192.168.3.205 but not outside the host (DNS, GW, Host A and internet).
Thanks in advance for your suggestions :)

    +----------------+    +----------------+       +-----------------+
    |      Host A    |    | GW:192.168.2.1 |       | DNS:192.168.2.1 |
    |  192.168.3.46  |    +----------------+       +-----------------+
    +----------------+            |                      |
            |                     |                      | network 192.168.2.0/23
 --------------------------------------------------------------------------------      
                               |
                    +----------------------+
                    |     192.168.2.48     |
                    |          |           |
                    |          |           |
                    |          |           |
                    |  +----------------+  |
                    |  |   ----------   |  |
                    |  |     BRIDGE     |  |
                    |  +----------------+  |
                    |          |           |
                    |          |           |
                    |  +----------------+  |
                    |  | 192.168.3.205  |  |
                    |  |    router      |  |
                    |  |   10.0.2.1     |  |
                    |  +----------------+  |
                    |          |           |
                    |          |           |
                    |          |           |
                    |  +----------------+  |
                    |  |    10.0.2.3    |  |
                    |  |    Instance    |  |
                    |  +----------------+  |
                    |                      |
                    +----------------------+



[UPDATE 1] I have the environment as shown in the scheme below :

 - Physical host  @192.168.3.46 :
 - Virtual host  @192.168.2.48 : where RDO all in one is deployed
 - OpenStack env :
              - External net : 192.168.2.0/23
              - Tenant subnet : 10.0.1.1/24
              - Router between them : 192.168.3.203, 10.0.1.1


From the local network 192.168.3.46 : I can ping all the elements of network (GW, DNS, 192.168.2.48)
From 192.168.2.48 : I can ping DNS, GW, Host A, router 192.168..3.205.
From router : I cannot outside the host (DNS, GW, Host A and internet). By tcpdumping i figured out that the interface eth0 listens to my icmp request but br-ex does not. i dont understand even if the ports are all connected to the bridge br-ex. here are the figures that may be relevant .. I wonder how it cannot work and I passed a lot of time with this situation tried solutions but nothing happen the same situation.


Thanks for any help you suggest to me :)

    +----------------+    +----------------+       +-----------------+
    |      Host A    |    | GW:192.168.2.1 |       | DNS:192.168.2.1 |
    |  192.168.3.46  |    +----------------+       +-----------------+
    +----------------+            |                      |
            |                     |                      | network 192.168.2.0/23
 --------------------------------------------------------------------------------      
                               |
                    +----------------------+
                    |     192.168.2.48     |
                    |          |           |
                    |          |           |
                    |          |           |
                    |  +----------------+  |
                    |  |   ----------   |  |
                    |  |     BRIDGE     |  |
                    |  +----------------+  |
                    |          |           |
                    |          |           |
                    |  +----------------+  |
                    |  | 192.168.3.203  |  |
                    |  |    router      |  |
                    |  |   10.0.1.1     |  |
                    |                      |
                    +----------------------+

Configuration files :


/etc/neutron/plugin.ini

[ml2]
type_drivers = vxlan,flat,vlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch

[ml2_type_flat]
flat_networks = *

[ml2_type_vlan]

[ml2_type_gre]

[ml2_type_vxlan]
vni_ranges =10:100
vxlan_group =224.0.0.1

[ml2_type_geneve]

[securitygroup]
enable_security_group = True


/etc/neutron/plugins/ml2/openvswitch_agent.ini

[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip =192.168.2.48
bridge_mappings = physnet1:br-ex
enable_tunneling=True

[agent]
polling_interval = 2
tunnel_types =vxlan, gre
vxlan_udp_port =4789
l2_population = False
arp_responder = False
prevent_arp_spoofing = True
enable_distributed_routing = False
drop_flows_on_start=False

[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver



[root@localhost ~]# ip netns exec qrouter-6bb53c5a-4561-4bdf-ae6b-b23e73bfa98a ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.3.203 icmp_seq=10 Destination Host Unreachable
From 192.168.3.203 icmp_seq=11 Destination Host Unreachable
From 192.168.3.203 icmp_seq=12 Destination Host Unreachable
From 192.168.3 ...
(more)
edit retag flag offensive close merge delete

Comments

Are you saying that you deployed Openstack inside Visualization Host 192.168.2.48 via some some virt mechanism using VMs belong internal vnet 10.0.2.0/24 ( supported && created by VirtHost 192.168.2.48 ) and at the moment you are missing outbound Internet connectivity for Openstack been

dbaxps gravatar imagedbaxps ( 2016-01-20 11:36:36 -0600 )edit

deployed inside VirtHost 192.168.2.28

dbaxps gravatar imagedbaxps ( 2016-01-20 11:37:45 -0600 )edit

I deployed OpenStack RDO AIO on VM 192.168.2.48. so my external network is 192.168.2.0/23. Network 10.0.2.0/24 is the private network created inside OpenStack

Wohard gravatar imageWohard ( 2016-01-20 14:02:31 -0600 )edit

What is IP of Virtualization Host running this VM ? Which kind of virtualization you have been using ?

dbaxps gravatar imagedbaxps ( 2016-01-20 14:37:46 -0600 )edit

The host on which resides the VM is in another VLAN. for the hypervisor it is a KVM (oVirt)

Wohard gravatar imageWohard ( 2016-01-21 08:49:28 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-16 07:17:43 -0600

Wohard gravatar image

The Question has been updated. But realy the question is how the ICMP request can be heard on eth0 and not in br-ex even if they are on the same ovs-bridge

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-20 10:26:25 -0600

Seen: 199 times

Last updated: Feb 16 '16