Ask Your Question
2

neutron-server cannot talk to AMQP

asked 2013-12-14 21:04:45 -0500

kbreit gravatar image

updated 2013-12-14 21:52:22 -0500

I am trying to get neutron-server working on a dedicated neutron node but it's not starting. Starting the process manually I see:

2013-12-14 21:03:35.729 16680 ERROR neutron.openstack.common.rpc.common [-] AMQP server on controller:5672 is unreachable: Socket closed. Trying again in 1 seconds.

However, if I try to telnet manually from that node I get:

Trying 10.200.1.1... Connected to controller. Escape character is '^]'.

Update:

Not sure if this is relevant or a red herring but I'm noticing some possibly odd behavior with how ports are bound. If I connect using telnet from the controller to the controller I see this.

telnet 3549 kbreit 3u IPv4 18115 0t0 TCP controller:60593->controller:amqp (ESTABLISHED)

However, if I connect using telnet from the neutron node to the controller, I don't see any similar lines show up.

I checked iptables and all three nodes in my network are set as ACCEPT for everything. Any suggestions?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
3

answered 2013-12-14 22:33:56 -0500

kbreit gravatar image

Turns out my username and password wasn't right for RabbitMQ. This command solved it:

rabbitmqctl change-password guest guest
edit flag offensive delete link more

Comments

I have a 3 node setup - so a Controller Node and a network node and did extensive debugging and also changed the password to other than guest in the conf files. Issuing the command above instantly resolved. Seems the rabbit_password is hardcoded to guest no matter your conf files.

jame gravatar imagejame ( 2014-06-07 15:47:14 -0500 )edit
1

answered 2013-12-14 21:18:00 -0500

SamYaple gravatar image

updated 2013-12-14 21:18:39 -0500

You need to give the correct hostname/ip address in the config file.

Sepcifically, change to this line in your neutron.conf file:

rabbit_host = 10.200.1.1
edit flag offensive delete link more

Comments

It appears to already have that properly setup as follows: root@neutron:/home/kbreit# cat /etc/neutron/neutron.conf | grep rabbit_host && ping controller rabbit_host = controller # rabbit_hosts is defaulted to '$rabbit_host:$rabbit_port' # rabbit_hosts = localhost:5672 PING controller (10.200.1.1) 56(84) bytes of data. 64 bytes from controller (10.200.1.1): icmp_req=1 ttl=64 time=0.243 ms

kbreit gravatar imagekbreit ( 2013-12-14 21:47:36 -0500 )edit

Do you have a properly resolvable FQDN in neutron.conf? Or is controller something defined in /etc/hosts? If the latter, does it work if you substitute controller for the IP?

jtopjian gravatar imagejtopjian ( 2013-12-14 22:15:04 -0500 )edit
0

answered 2013-12-15 19:02:33 -0500

laocius gravatar image

first, ensure that qpid is running on your controller node; second, check 'qpid_hostname' and qpid_port in you neutron.conf.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-14 21:04:45 -0500

Seen: 3,136 times

Last updated: Dec 15 '13