Ask Your Question
0

neutron.agent.l3.router_info: Cannot create namespace file "...": File exists

asked 2016-01-19 12:34:04 -0500

Chalmc80 gravatar image

updated 2016-01-28 10:37:03 -0500

Hi All,

I have just completed a clean installation following http://docs.openstack.org/liberty/ins... on CentOS 7 but am getting the below error when creating a new router through the GUI and CLI. All the ports are 'Status Down' on the 'Router Details' page.

Tried restarting the services and controller node but issue persists. Double checked my configuration files everythings looks correct from the OpenStack guide.

I don't see any errors in the other /var/log/neutron logs.


2016-01-19 18:24:02.793 914 ERROR neutron.agent.linux.utils [-]
Command: ['ip', 'netns', 'add', u'qrouter-56bc779f-a82c-44a1-80d1-cc11253e4d48']
Exit code: 1
Stdin:
Stdout:
Stderr: Cannot create namespace file "/var/run/netns/qrouter-56bc779f-a82c-44a1-80d1-cc11253e4d48": File exists

2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info [-]
Command: ['ip', 'netns', 'add', u'qrouter-56bc779f-a82c-44a1-80d1-cc11253e4d48']
Exit code: 1
Stdin:
Stdout:
Stderr: Cannot create namespace file "/var/run/netns/qrouter-56bc779f-a82c-44a1-80d1-cc11253e4d48": File exists
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info Traceback (most recent call last):
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/common/utils.py", line 356, in call
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     return func(*args, **kwargs)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 694, in process
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     self.process_external(agent)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 660, in process_external
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     self._process_external_gateway(ex_gw_port, agent.pd)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 569, in _process_external_gateway
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     self.external_gateway_added(ex_gw_port, interface_name)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 534, in external_gateway_added
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     ex_gw_port, interface_name, self.ns_name, preserve_ips)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 496, in _external_gateway_added
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     self._plug_external_gateway(ex_gw_port, interface_name, ns_name)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/l3/router_info.py", line 477, in _plug_external_gateway
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     prefix=EXTERNAL_DEV_PREFIX)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info   File "/usr/lib/python2.7/site-packages/neutron/agent/linux/interface.py", line 252, in plug
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info     bridge, namespace, prefix)
2016-01-19 18:24:02.865 914 ERROR neutron.agent.l3.router_info ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-01-28 11:02:09 -0500

updated 2016-01-28 11:02:24 -0500

Hi, i think you are facing a bug with iproute2.

https://bugs.launchpad.net/neutron/+bug/1528977

As a workaround, they suggest downgrade iproute package:

# wget http://mirror.centos.org/centos/7.1.1503/os/x86_64/Packages/iproute-3.10.0-21.el7.x86_64.rpm
# yum -y downgrade ./iproute-3.10.0-21.el7.x86_64.rpm

A patch is provided: https://review.openstack.org/#/q/I0d3fc4262284172f5ad31e4f2f78ae1fb33b4228,n,z

Check if that is your issue.

Regards

edit flag offensive delete link more
0

answered 2016-01-21 01:58:18 -0500

Tiloo gravatar image

It's similar as my question。 https://ask.openstack.org/en/question/87780/ip-netns-show-qrouter-f426d040-b7f8-4ad5-8a06-afce448e6e2e-id-2/ (https://ask.openstack.org/en/question...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-19 12:34:04 -0500

Seen: 742 times

Last updated: Jan 28 '16