Ask Your Question
1

After adding ovs br-ex on physical public network, server connection lost

asked 2016-01-16 03:35:59 -0500

anonymous user

Anonymous

i am facing the bridge mapping problem, after adding the ovs external interface br-ext to the ext1 (physical public interface), connection lost to the server. I have applied manual configuration whatever mention in other blogs, but still issue is there.

Thank you very much for your reply.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-07-21 06:33:54 -0500

Ionel gravatar image

I am in the same situation. I have installed openstack using devstack. Now I am at the point of linking br-ex interface to an external interface. I have used the above commands (ovs-vsctl , etc) and now I cannot access anymore my external interface only the br-ex interface IP. External interface is setup to use DHCP, is getting the IP but is not accessible from outside. When I am powering on instances they are hanging on powering on state. At the end, I have managed to regain access to external interface using command ovs-vsctl del-port br-ex ens160 Any suggestion to solve this situation ?

edit flag offensive delete link more
1

answered 2016-01-18 05:16:27 -0500

Wohard gravatar image

have a look on this link . https://www.rdoproject.org/networking/neutron-with-existing-external-network/ (https://www.rdoproject.org/networking...)
you can create the interface fie if not already done.

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.122.212 # Old eth0 IP since we want the network restart to not 
                       # kill the connection, otherwise pic your something outside your dhcp range
NETMASK=255.255.255.0  # your netmask
GATEWAY=192.168.122.1  # your gateway
DNS1=192.168.122.1     # your nameserver
ONBOOT=yes


And change the config file of your physical interface

DEVICE=eth0
HWADDR=52:54:00:92:05:AE # your hwaddr (find via ip link show eth0)
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes
edit flag offensive delete link more
0

answered 2016-01-18 05:07:43 -0500

smcas gravatar image

Assuming eth0 or ext1 interface is having internet access and br-ex bridge is set up,

ovs-vsctl add-port br-ex eth1

this command will disconnect the acess of node, Login to console and set

ifcfg eth1 0

Also ensure that br-ex is having the public ip address or the inter access network, if not , see it via CLI

ifconfig br-ex <ip-address> netmask 255.x.x.x up

This would bring back the connectivity.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-16 03:35:59 -0500

Seen: 4,590 times

Last updated: Jan 18 '16