Ask Your Question

Enabling Monasca Graphana GUI from Horizon

asked 2016-01-14 11:21:27 -0500

Pradip gravatar image


I followed the instructions mentioned to install the Monasca Horizon plugin. I can able to see the Monitor tab in the Horizon. However could not able to launch the Graphana UI (Monasca UI) from the Horizon, getting such an error as Page Not Found. Any clus?

 Using the URLconf defined in openstack_dashboard.urls, Django tried these URL patterns, in this order:

    ^$ [name='splash']
    ^home/$ [name='user_home']
    ^i18n/js/(?P<packages>\S+?)/$ [name='jsi18n']
    ^i18n/setlang/$ [name='set_language']
    ^jasmine-legacy/$ [name='jasmine_tests']

The current URL, grafana/index.html, didn't match any of these.
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-02-12 09:43:15 -0500

Pradip gravatar image

It has nothing to do with Monasca, rather Apache2 setup.

The whole thing is in apache_document_root where you need to symbol link this

ln -r -s grafana/src apache_document_root/grafana

Can try out the following steps:

  1. Inside /etc/apache2/sites-available/, copy the 000-default.conf to 001-default.conf
  2. Change it : DocumentRoot /var/www/grafana
  3. In /var/www, put a ln -s graphana/src to /var/www/grafana
  4. sudo a2dissite 000-default && sudo a2ensite 001-default
  5. sudo service apache2 reload
  6. sudo service apache2 restart
  7. Restart horizon (./ --runserver)

Hope this might help.


edit flag offensive delete link more


what is the username, password for horizon login from dashboard. because it does not ask for one

Awais gravatar imageAwais ( 2016-02-15 01:57:06 -0500 )edit

Depends on your Monasca setup. Typically user is mini-mon, password is password.

Pradip gravatar imagePradip ( 2016-02-15 03:05:15 -0500 )edit

answered 2018-08-02 03:04:05 -0500

May i know how installed the Monasca Horizon plugin using

I have followed below steps

1) Devstack- ocata version is running 2) git clone -b stable/ocata 3) As per In devstack already have horizon directory under /opt/stack/horizon so i moved to next steps like 4) Added git+ to requirements.txt 5) pip install -r requirement.txt 6) under "openstack_dashboard/" added "import monitoring.enabled" & "monitoring.enabled, (Add this line to the settings.utils_update_dashboards list" 7) Created symlink as below

ln -sf $(pwd)/../monasca-ui/monitoring/enabled/ \ $(pwd)/openstack_dashboard/enabled/ ln -sf $(pwd)/../monasca-ui/monitoring/conf/monitoring_policy.json \ $(pwd)/openstack_dashboard/conf/monitoring_policy.json ln -sfF $(pwd)/../monasca-ui/monitoring $(pwd)/monitoring

8) under /opt/stack/horizon >> "python compress" getting error as below

Traceback (most recent call last): File "", line 23, in <module> execute_from_command_line(sys.argv) File "/usr/local/lib/python2.7/dist-packages/django/core/management/", line 354, in execute_from_command_line utility.execute() File "/usr/local/lib/python2.7/dist-packages/django/core/management/", line 303, in execute settings.INSTALLED_APPS File "/usr/local/lib/python2.7/dist-packages/django/conf/", line 48, in __getattr__ self._setup(name) File "/usr/local/lib/python2.7/dist-packages/django/conf/", line 44, in _setup self._wrapped = Settings(settings_module) File "/usr/local/lib/python2.7/dist-packages/django/conf/", line 92, in __init__ mod = importlib.import_module(self.SETTINGS_MODULE) File "/usr/lib/python2.7/importlib/", line 37, in import_module __import__(name) File "/opt/stack/horizon/openstack_dashboard/", line 444, in <module> INSTALLED_APPS, File "/opt/stack/horizon/openstack_dashboard/utils/", line 112, in update_dashboards for key, config in import_dashboard_config(modules): File "/opt/stack/horizon/openstack_dashboard/utils/", line 45, in import_dashboard_config for key, submodule in import_submodules(module).items(): File "/opt/stack/horizon/openstack_dashboard/utils/", line 30, in import_submodules submodule = import_module(name) File "/usr/lib/python2.7/importlib/", line 37, in import_module __import__(name) File "/opt/stack/horizon/openstack_dashboard/enabled/", line 35, in <module> 'recoverable': (exc.HTTPUnProcessable, exc.HTTPConflict, exc.HTTPException), AttributeError: 'module' object has no attribute 'HTTPUnProcessable'

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-01-14 11:21:27 -0500

Seen: 1,414 times

Last updated: Aug 02 '18