Ask Your Question

Keystone Liberty installation fails on openstack command

asked 2016-01-14 08:01:46 -0500

garcianavalon gravatar image

Hi all,

I've tried following the instructions found in ( to install Keystone on a clean Ubuntu 14.

My problem comes when trying to connect to Keystone using the openstack cli:

$ openstack service create   --name keystone --description "OpenStack Identity" identity
usage: openstack service create [-h] [-f {shell,table}] [-c COLUMN]
                                [--variable VARIABLE] [--prefix PREFIX]
                                [--name <service-name>] [--enable | --disable]
openstack service create: error: unrecognized arguments: --description identity

any idea why is this happening? Thanks!

edit retag flag offensive close merge delete


What python-openstackclient version you use? It should have a --description option

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-01-14 09:41:27 -0500 )edit

@Eduardo I'm using 0.3.0, the one that comes with apt-get. Is it too old?

garcianavalon gravatar imagegarcianavalon ( 2016-01-15 03:25:53 -0500 )edit

I think so, current python-openstackclient version now is 1.7.0 at least in Ubuntu 15.10, probably there is a bug with your version that not comes with --description option. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-01-15 03:54:56 -0500 )edit

thanks for your answer!

garcianavalon gravatar imagegarcianavalon ( 2016-01-15 04:14:01 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2016-01-15 04:17:23 -0500

garcianavalon gravatar image

updated 2016-01-15 06:17:10 -0500

Updated answer.

@Eduardo Gonzalez was right in that my openstackclient package was outdated. After looking around and checking things I discovered that I wasn't fetching correctly the Liberty release repositories. If you encounter the same error, make sure to:

# apt-get install software-properties-common
# add-apt-repository cloud-archive:liberty
# apt-get update && apt-get dist-upgrade

and if it fails check this answer: (

edit flag offensive delete link more

answered 2016-07-01 10:51:04 -0500

6543217890meh gravatar image

I also had an issue with the following error: ContextualVersionConflict: (requests 1.2.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('requests>=2.5.2'), set(['python-keystoneclient'])). I am not upgrading, but starting with a fresh install of liberty on Ubuntu 14.04. My setting for repository were also correct. Since I did not find a good solution to my problem I struggled for days. I finally solved the problem by installing "pip" and forcing the python-keystoneclient to upgrade to the correct package. I have also found that a simpler way to fix the issue is to do a apt-get upgrade python-keystoneclient after I install. You would think that since you are doing a fresh install the packages would be the most current version, but for some reason this was not the case. The upgrade finds packages to upgrade. After I did this keystone started working correctly.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-01-14 08:01:46 -0500

Seen: 848 times

Last updated: Jul 01 '16