Ask Your Question
2

lliberty cannot ping qrouter gateway

asked 2016-01-13 06:24:13 -0500

BM Shukla gravatar image

updated 2016-01-13 06:40:58 -0500

Please refer the following outputs

[root@controller3 ~]# ip netns
qrouter-af524c91-516d-4375-aee9-75595bcba769 (id: 1)
qdhcp-cd9b17c1-f14d-4888-b925-ee9b52dbb48e (id: 3)
qdhcp-15f89395-6d8b-4576-8a4e-e3a4b64e1ef7 (id: 0)


 [root@controller3 ~]# neutron router-port-list router
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 6abd55f0-f96d-4ec7-b980-0a9d20557ba3 |      | fa:16:3e:ce:f1:12 | {"subnet_id": "2f58d428-5169-43fc-8104-ece124c6a26d", "ip_address": "192.168.0.254"} |
| d1349c65-d5ea-4124-8982-fcda9c9ecf8d |      | fa:16:3e:0c:bf:59 | {"subnet_id": "85fa318b-d87e-4fd1-b53e-766383853cac", "ip_address": "172.27.0.7"}    |
+--------------------------------------+------+-

I am unable to ping "172.27.0.7". Also on dashboard router icon does not show this interface. I am using my departmental network 172.27.0.0/16 as public network and 192.168.0.0/16 as private network. My compute nodes are using 2 NICs (one 10.0.0.x and other one in unnumbered) My controller has 3 NIC (10.0.0x, 172.27.16.x and one unnumbered) please see below.

[root@controller3 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master brqcd9b17c1-f1 state UP qlen 1000
    link/ether a0:36:9f:a1:42:40 brd ff:ff:ff:ff:ff:ff
3: enp1s0f1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
4: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.27.16.31/16 brd 172.27.255.255 scope global eno1
       valid_lft forever preferred_lft forever
5: eno2: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
6: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.13/24 brd 10.0.0.255 scope global bond0
       valid_lft forever preferred_lft forever
7: tape2e82c07-71@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether aa:9a:ce:71:51:0e brd ff:ff:ff:ff:ff:ff link-netnsid 0
10: brqcd9b17c1-f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 46:4f:a3:14:a4:47 brd ff:ff:ff:ff:ff:ff
11: tapa4b98a60-1b@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master brqcd9b17c1-f1 state UP qlen 1000
    link/ether 46:4f:a3:14:a4:47 brd ff:ff:ff:ff:ff:ff link-netnsid 3
16: tap6abd55f0-f9@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 4e:7c:3e:b7:e2:7b brd ff:ff:ff:ff:ff:ff link-netnsid 
----
[root@controller3 ~]# ip netns exec qrouter-af524c91-516d-4375-aee9-75595bcba769 ip a
1: lo: <LOOPBACK,UP,LOWER_UP ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-06 04:52:08 -0500

jonathan gravatar image

updated 2016-04-06 04:55:03 -0500

I had the same issue and i solved it just by reinstalling neutron (uninstalling all packages related to neutron and installing and editing the config files again). I also have to reinstall nova and horizon in the controller node as they were uninstalled too.

To debug it this problem first i get the neutron agent list:

# neutron agent-list

and shows that one of the linux bridge agents is not running (in my case the one in the controller node), the field 'Alive' is XXX. Also, the port in the router that acts as the interface of the public network shows that the binding:vif_type is binding_fail:

# neutron port-show <id-puerto-router-gateway>
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| Field                 | Value                                                                                                                 |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                                                  |
| allowed_address_pairs |                                                                                                                       |
| binding:host_id       | puccini                                                                                                               |
| binding:profile       | {}                                                                                                                    |
| binding:vif_details   | {"port_filter": true}                                                                                                 |
| binding:vif_type      | binding_fail                                                                                                               |
| binding:vnic_type     | normal                                                                                                                |
| device_id             | ccb7fd27-a791-4033-96ab-6aee33edcbda                                                                                  |
| device_owner          | network:router_gateway                                                                                                |
| dns_assignment        | {"hostname": "host-163-117-141-129", "ip_address": "163.117.141.129", "fqdn": "host-163-117-141-129.openstacklocal."} |
| dns_name              |                                                                                                                       |
| extra_dhcp_opts       |                                                                                                                       |
| fixed_ips             | {"subnet_id": "7f6d387c-4edb-4e52-a594-0cbd67712c3a", "ip_address": "163.117.141.129"}                                |
| id                    | c13cad36-05d9-405e-a677-d95c3ea01d6b                                                                                  |
| mac_address           | fa:16:3e:f4:36:39                                                                                                     |
| name                  |                                                                                                                       |
| network_id            | 3a39126e-748b-45b5-8169-6eee192fae29                                                                                  |
| port_security_enabled | False                                                                                                                 |
| security_groups       |                                                                                                                       |
| status                | DOWN                                                                                                                |
| tenant_id             |                                                                                                                       |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+

It is also worth mentioning that the official guide of liberty installation lacks some configuration parameters (as described https://bugs.launchpad.net/nova/+bug/1519641/comments/18 (here) and https://bugs.launchpad.net/nova/+bug/1519641/comments/22 (here), which causes the following failure when trying to boot instances:

ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.<class 'keystoneclient.exceptions.BadRequest'> (HTTP 500) (Request-ID: req-7acc4f88-51fc-4c0b-9748-361a2e9a6ad9)

Jonathan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-01-13 06:24:13 -0500

Seen: 106 times

Last updated: Apr 06 '16