Ask Your Question
0

Two-node RDO install with bridged external networking not working

asked 2016-01-12 19:30:27 -0500

campee gravatar image

OS=Linux Distro=CentOS7

I used RDO to set up a lab with two systems running inside of KVM; one compute node and a 'control' system running neutron, glance, keystone, horizon, etc. Each system has two network interfaces, eth0 and eth1, both on the same network: 192.168.122.0/24 On each server eth0 is assigned a static IP address and is used for management traffic. eth1 is for Neutron, and currently does not have an IP configuration on either host I want to assign eth1 to an OVS bridge named br-ex, which RDO installed by default, and have instances created on the compute node to be assigned IP addresses by the DHCP server running on my lab network, not by a router within OpenStack. As I understand it, this is referred to as a "service provider" network.

I ran the following on my 'control' node to associate eth1 with br-ex: ovs-vsctl add-port br-ex eth1

br-ex shows the following now:

Bridge br-ex
    Port br-ex
        Interface br-ex
            type: internal
    Port "eth1"
        Interface "eth1"

I changed ifcfg-eth1 to look like this:

DEVICE=eth1
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

And changed ifcfg-br-ex to look like this:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
ONBOOT=yes

1st question: I actually don't see 'br-ex' on my compute node when I run 'ovs-vsctl show' but I do see it on the 'control' node. Why is that? Is it normal?

I then tried to set up external bridged networking by following http://community.redhat.com/blog/2015/01/rdo-quickstart-doing-the-neutron-dance/ (http://community.redhat.com/blog/2015...)

Then I ran these commands on my Neutron host:

root@openstack-control ~(keystone_admin)]# neutron net-create public --router:external=True
Created a new network:
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | b1e9055c-3ded-4b45-a8ac-445de57d10c6 |
| mtu                       | 0                                    |
| name                      | public                               |
| provider:network_type     | vxlan                                |
| provider:physical_network |                                      |
| provider:segmentation_id  | 57                                   |
| router:external           | True                                 |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   |                                      |
| tenant_id                 | 0290aec78d0045c981a740ee540e6be6     |
+---------------------------+--------------------------------------+


root@openstack-control ~(keystone_admin)]# neutron subnet-create --name public_subnet --enable_dhcp=False --allocation_pool start=192.168.122.100,end=192.168.122.130 --gateway=192.168.122.1 public 192.168.122.0/24
Created a new subnet:
+-------------------+--------------------------------------------------------+
| Field             | Value                                                  |
+-------------------+--------------------------------------------------------+
| allocation_pools  | {"start": "192.168.122.100", "end": "192.168.122.130"} |
| cidr              | 192.168.122.0/24                                       |
| dns_nameservers   |                                                        |
| enable_dhcp       | False                                                  |
| gateway_ip        | 192.168.122.1                                          |
| host_routes       |                                                        |
| id                | f1aee2ee-02c9-46c0-9fa9-5b1d53c36d55                   |
| ip_version        | 4                                                      |
| ipv6_address_mode |                                                        |
| ipv6_ra_mode      |                                                        |
| name              | public_subnet                                          |
| network_id        | b1e9055c-3ded-4b45-a8ac-445de57d10c6                   |
| subnetpool_id     |                                                        |
| tenant_id         | 0290aec78d0045c981a740ee540e6be6                       |
+-------------------+--------------------------------------------------------+


root@openstack-control ~(keystone_admin)]# neutron router-create router1
Created a new router:
+-----------------------+--------------------------------------+
| Field                 | Value                                |
+-----------------------+--------------------------------------+
| admin_state_up        | True                                 |
| distributed           | False                                |
| external_gateway_info |                                      |
| ha                    | False                                |
| id                    | 4dadca55-88ae-4501-8530-6b5080832460 |
| name                  | router1                              |
| routes                |                                      |
| status                | ACTIVE                               |
| tenant_id             | 0290aec78d0045c981a740ee540e6be6     |
+-----------------------+--------------------------------------+


root@openstack-control ~(keystone_admin)]# neutron router-gateway-set router1 public
Set gateway for router router1

I created a security group called 'wide_open' that should allow any traffic:

root@openstack-control ~(keystone_admin)]# nova secgroup-list-rules wide_open
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
| udp         | 1         | 65535   | 0.0.0.0/0 |              |
| tcp         | 1         | 65535   | 0.0.0.0/0 |              |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
+-------------+-----------+---------+-----------+--------------+

I then created an instance using Fedora 23's cloud image, Fedora-Cloud-Base-23-20151030.x86_64.qcow2, and gave the instance a name ... (more)

edit retag flag offensive close merge delete

Comments

Upload somewhere your answer-file,ovs-vsctl show,ifconfig on each node
Make link available to see your stuff.

dbaxps gravatar imagedbaxps ( 2016-01-13 07:01:46 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-01-13 10:45:46 -0500

dbaxps gravatar image

updated 2016-01-13 10:57:13 -0500

See:- https://www.linux.com/community/blogs...
Get concept of using several pre-created libvirt networks for VMs setup as RDO nodes.
Then update answer-file corespondently.

CONFIG_CONTROLLER_HOST=192.169.142.127
CONFIG_COMPUTE_HOSTS=192.169.142.137
CONFIG_NETWORK_HOSTS=192.169.142.127

Also have VTEPS IPs setup, before running packstack.
Make OVS configuration for in/outbound connectivity on Controller/Network Node.
In general VM running Controller/Network is supposed to 3 VNICs

1. Exeternal
2. Management.
3. VTEP's

Otherwise , your External net would be the same as Mgmt net.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-12 19:30:27 -0500

Seen: 395 times

Last updated: Jan 13 '16