Ask Your Question
0

heatclient.exc.HTTPInternalServerError: ERROR: Remote error: UnsupportedVersion Endpoint does not support RPC version 1.8

asked 2016-01-12 14:09:36 -0500

nutshi gravatar image

updated 2016-01-19 14:12:55 -0500

I upgrade heat to liberty Restarted heat services

and this what i am getting any pointers?

heatclient.exc.HTTPInternalServerError: ERROR: Remote error: UnsupportedVersion Endpoint does not support RPC version 1.8.


None. 2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi Traceback (most recent call last):

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/common/wsgi.py", line 854, in __call__

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi request, **action_args)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/common/wsgi.py", line 928, in dispatch

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi return method(args, *kwargs)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/api/openstack/v1/util.py", line 38, in handle_stack_method

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi return handler(controller, req, **kwargs)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/api/openstack/v1/stacks.py", line 340, in index

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi return self._index(req)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/api/openstack/v1/stacks.py", line 298, in _index 2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi **params) 2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/rpc/client.py", line 143, in list_stacks 2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi version='1.8') 2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/heat/rpc/client.py", line 61, in call

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi return client.call(ctxt, method, **kwargs)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/oslo_messaging/rpc/client.py", line 158, in call

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi retry=self.retry)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/oslo_messaging/transport.py", line 90, in _send

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi timeout=timeout, retry=retry)

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/oslo_messaging/_drivers/amqpdriver.py", line 464, in send

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi def cleanup(self):

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi File "/opt/heat/lib/python2.7/site-packages/oslo_messaging/_drivers/amqpdriver.py", line 455, in _send

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi

2016-01-19 20:04:29.009 11161 ERROR heat.common.wsgi RemoteError: Remote error: UnsupportedVersion Endpoint does not support RPC version 1.8. Attempted method: list_stacks

2016-01-19 20:04 ...

(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-02-01 15:47:15 -0500

nutshi gravatar image

yeah restarting all heat nodes fixed the issue

edit flag offensive delete link more
0

answered 2016-02-01 11:28:45 -0500

zaneb gravatar image

It looks like you've upgraded heat-api but there is at least one old heat-engine process still running.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-12 14:09:36 -0500

Seen: 311 times

Last updated: Feb 01 '16