Installing Manila fails in neutrol setup

asked 2016-01-12 05:04:38 -0500

Pradip gravatar image

I am trying to setup Manila with the following local.conf. And consistently getting one or other neutrol file is missing:

/opt/stack/neutron/etc/neutron.conf
/opt/stack/neutron/etc/neutron/plugins/ml2/ml2_conf.ini
/opt/stack/neutron/etc/dhcp_agent.ini
metadata_agent.ini

Looks like some of those are kept inside here:

stack@openstack1:/opt/stack/neutron$ find . -name metadata_agent.ini
./etc/oslo-config-generator/metadata_agent.ini

Am I missing something in the configuration ?

Here is the local.conf:

[[local|localrc]]
// all the passwords settings

disable_service horizon
disable_service n-net

enable_service neutron
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta

enable_plugin manila https://github.com/openstack/manila

Q_PLUGIN=ml2
ENABLE_TENANT_VLANS=True
ML2_VLAN_RANGES=physnet1:100:200
PHYSICAL_NETWORK=physnet1
OVS_PHYSICAL_BRIDGE=br-eth1
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=vlan,vxlan


[[post-config|$MANILA_CONF]]
[DEFAULT]
MANILA_ENABLED_BACKENDS=my_backend
MANILA_ENABLED_SHARE_PROTOCOLS=NFS

[my_backend]
share_backend_name=my_backend
   ...........
  ..........
edit retag flag offensive close merge delete